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Disclaimer and Software License Agreement 
DTLINK, LLC, INC. ("DTLINK") IS WILLING TO LICENSE THE SOFTWARE ONLY UPON THE 

CONDITION THAT YOU ACCEPT ALL OF THE TERMS CONTAINED IN THIS SOFTWARE 

LICENSE AGREEMENT.  PLEASE READ THE TERMS CAREFULLY.  BY CLICKING ON "YES, 

ACCEPT", YOU WILL INDICATE YOUR AGREEMENT WITH THEM.  IF YOU DO NOT AGREE 

WITH THESE TERMS, THEN DTLINK IS UNWILLING TO LICENSE THE SOFTWARE TO YOU. 

 

SOFTWARE LICENSE AGREEMENT AND WARRANTY STATEMENT 

(End-User Perpetual License/Redistribution Prohibited) 

 

1. The Software; Trademarks.  The Software licensed under this Agreement consists of computer 

programs, data compilation(s), and documentation owned by DTLink and marketed under DTLink's 

trademark  Personal Stock Monitor™  (the "Software").   

 

2. Perpetual Term For Registered Version License.  The term of the license granted herein for the 

registered version of the Software shall be perpetual unless terminated by written notice by You for 

convenience or terminated by either party for material breach.  Immediately upon termination of this 

license for any reason, You shall return to DTLink all copies of the Software and documentation. 

 

3. License Grant.  If You are a registered user of the Software, You are granted non-exclusive rights 

to install and use the Software by a single person who uses the Software only on one or  more computers or 

workstations.  You may copy the Software for archival purposes, provided that any copy must contain the 

original Software's proprietary notices in unaltered form.  You are granted non-exclusive rights to install 

and use the Software with authorized third-party websites for purposes of polling for data regarding stock 

price quotes and/or authorized trade execution services (both referred to as "Authorized Third Party 

Services"). 

 

4. Restrictions.  You may not: (i) permit others to use the Software; (ii) modify or translate the 

Software; (iii) reverse engineer, decompile, or disassemble the Software, except to the extent this restriction 

is expressly prohibited by applicable law; (iv) create derivative works based on the Software; (v) merge the 

Software with another product; (vi) copy the Software, except as expressly provided above; or (vii) remove 

or obscure any proprietary rights notices or labels on the Software. 

 

5. Transfers.  You may not transfer the Software or any rights under this Agreement without the prior 

written consent of DTLink, which consent shall not be unreasonably withheld.  A condition to any transfer 

or assignment shall be that the recipient agrees to the terms of this Agreement.  Any attempted transfer or 

assignment in violation of this provision shall be null and void. 

 

6. Ownership.  DTLink and its suppliers own the Software and all intellectual property rights 

embodied therein, including copyrights and valuable trade secrets embodied in the Software's design and 

coding methodology.  The Software is protected by United States copyright laws and international treaty 

provisions.  This Agreement provides You only a limited use license, and no ownership of any intellectual 

property. 

 

7. Monitoring Rights; Privacy.  DTLink reserves the right to monitor your use of the Software, but 

DTLink does not reserve the right to collect or use any of your data processing information.  DTLink also 

reserves the right to collect and archive any of the personal information which you entered during the 

registration process for this Software ("Registration Data").  DTLink will limit its use of your Registration 

Data to improving the Software and for purposes of providing technical support.  DTLink will not share 

your Registration Data with others, except for affiliates, successors in a sale or merger of our business, or in 

the unlikely event of bankruptcy, insolvency, reorganization, or receivership, or in response to legal 

process; however, DTLink reserves the right to provide access to its servers and databases to third party 

service providers who agree to maintain confidentiality of any Registration Data to which they may have 

access. 
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8. Software Upgrades.  Commencing with the date of your purchase of this license and continuing 

for one year, DTLink will provide your with upgrades to the Software at no additional charge.  You may 

purchase rights for additional Software upgrades thereafter at DTLink's then-current fee. 

 

WARRANTY DISCLAIMER; LIMITATION OF LIABILITY.  DTLINK PROVIDES THE SOFTWARE 

"AS-IS."  NEITHER DTLINK NOR ANY OF ITS AUTHORIZED THIRD PARTY SERVICES, 

SUPPLIERS, OR RESELLERS MAKES ANY WARRANTY OF ANY KIND, EXPRESS OR IMPLIED.  

DTLINK AND ITS AUTHORIZED THIRD PARTY SERVICES, SUPPLIERS, AND RESELLERS 

SPECIFICALLY DISCLAIM THE IMPLIED WARRANTIES OF TITLE, NON-INFRINGEMENT, 

MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, SYSTEM INTEGRATION, AND 

DATA ACCURACY.  THERE IS NO WARRANTY OR GUARANTEE THAT YOUR USE OF THE 

SOFTWARE AND AUTHORIZED THIRD PARTY SERVICES WILL PRODUCE ANY SPECIFIC 

RESULT; YOU ASSUME SOLE AND EXCLUSIVE RESPONSIBILITY FOR YOUR USE OF THE 

SOFTWARE IN CONNECTION WITH YOUR INVESTMENT DECISIONS AND SECURITIES 

TRADING ACTIVITIES.  THERE IS NO WARRANTY OR GUARANTEE THAT THE OPERATION 

OF THE SOFTWARE WILL BE UNINTERRUPTED, ERROR-FREE, OR VIRUS-FREE, OR THAT 

THE SOFTWARE WILL MEET ANY PARTICULAR CRITERIA OF PERFORMANCE, QUALITY, 

ACCURACY, PURPOSE, OR NEED.  YOU ASSUME THE ENTIRE RISK OF SELECTION, 

INSTALLATION, AND USE OF THE SOFTWARE.  THIS DISCLAIMER OF WARRANTY 

CONSTITUTES AN ESSENTIAL PART OF THIS AGREEMENT.  NO USE OF THE SOFTWARE IS 

AUTHORIZED HEREUNDER EXCEPT UNDER THIS DISCLAIMER.  Under local law, certain 

limitations may not apply, and you may have additional rights which vary from state to state. 

 

YOU ACKNOWLEDGE AND AGREE THAT DTLINK HAS NO CONTROL OVER THE PROVISION 

OF AUTHORIZED THIRD PARTY SERVICES OR PROVISION OF ACCESS TO THE AUTHORIZED 

THIRD PARTY SERVICES, DOES NOT GUARANTEE THAT YOU WILL BE ABLE TO USE THE 

SOFTWARE WITH THE AUTHORIZED THIRD PARTY SERVICES, AND WILL HAVE NO 

LIABILITY WHATSOEVER FOR ANY ACTIONS OR INACTIONS ON THE PART OF THE 

PROVIDERS OF AUTHORIZED THIRD PARTY SERVICES RESULTING IN YOUR INABILITY TO 

USE THE SOFTWARE TO ACCESS YOUR ACCOUNTS, OBTAIN DATA AND STOCK QUOTES, 

EXECUTE TRADES, DOWNLOAD TRANSACTIONS, OR OTHERWISE USE OR ACCESS THE 

AUTHORIZED THIRD PARTY SERVICES. 

 

INDEPENDENT OF THE FORGOING PROVISIONS, IN NO EVENT AND UNDER NO LEGAL 

THEORY, INCLUDING WITHOUT LIMITATION, TORT, CONTRACT, OR STRICT PRODUCTS 

LIABILITY, SHALL DTLINK OR ANY OF THEAUTHORIZED THIRD PARTY SERVICES, 

SUPPLIERS, OR RESELLERS BE LIABLE TO YOU OR ANY OTHER PERSON FOR ANY 

INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF ANY KIND, 

INCLUDING WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL, WORK 

STOPPAGE, COMPUTER MALFUNCTION, OR ANY OTHER KIND OF COMMERCIAL DAMAGE, 

EVEN IF DTLINK OR ANY AFFECTED AUTHORIZED THIRD PARTY SERVICE, SUPPLIER, OR 

RESELLER HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.  THIS 

LIMITATION SHALL NOT APPLY TO LIABILITY FOR DEATH OR PERSONAL INJURY TO THE 

EXTENT PROHIBITED BY APPLICABLE LAW. 

 

IN NO EVENT SHALL DTLINK'S LIABILITY FOR TOTAL AGGREGATE DAMAGES FOR ANY 

CAUSE WHATSOEVER, AND REGARDLESS OF THE FORM OF ACTION, EXCEED THE 

AMOUNT OF THE PURCHASE PRICE PAID, IF ANY, FOR THE SOFTWARE LICENSE. 

 

EXPORT PROHIBITION.  The Software is intended for use in the United States only.  By your acceptance 

of the Software as indicated above, You agree not to transmit or otherwise export the Software or 

underlying information or technology from the United States. 

 

MISCELLANEOUS.  This Agreement constitutes the entire understanding of the parties with respect to the 

subject matter of this Agreement and merges all prior communications, representations, and agreements. 

This Agreement may be modified only by a written agreement signed by the parties.  If any provision of 
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this Agreement is held to be unenforceable for any reason, such provision shall be reformed only to the 

extent necessary to make it enforceable.  This Agreement shall be construed under the laws of the State of 

Maryland, USA, excluding rules regarding conflicts of law.  This license is written in English and English 

is its controlling language. 

 

U.S. GOVERNMENT END USERS.  The Software is a "commercial item," as that term is defined in 48 

C.F.R. 2.101 (Oct. 1995), consisting of "commercial computer software" and "commercial computer 

software documentation," as such terms are used in 48 C.F.R. 12.212 (Sept. 1995). Consistent with 48 

C.F.R. 12.212 and 48 C.F.R. 227.7202-1 through 227.7202-4 (June 1995), all U.S. Government End Users 

acquire the Software with only those rights as are granted to all other end users pursuant to the terms and 

conditions herein. Unpublished-rights reserved under the copyright laws of the United States.  

 



 8 

1. Introduction 

About Personal Stock Monitor 

Thank you for choosing Personal Stock Monitor, the desktop companion for informed investors.  First 

released in 1996, Personal Stock Monitor has become one of the premier investment tracking and portfolio 

management applications on the Internet.  Our customers include everyone from first-time investors to 

people managing multi-million dollar portfolios, and the software helps them all keep better track of their 

investments and make timely and informed decisions. 

System Requirements 

Minimum requirements: 

 Windows 98, ME, 2000, XP, 2003, Vista, Windows 7, or later 

 Pentium-class processor 

 64MB RAM 

 800x600 video 

 10MB hard drive space 

 Dial-up internet connection 

 

Recommended: 

 Pentium 4-class processor 

 256 MB RAM 

 20 MB free disk space 

 High-speed internet connection 

 

2. Installation 
 

To install Personal Stock Monitor simply double-click on the distribution file.  This file should be called 

something like psm90g_install.exe (for 9.0 Gold) if you downloaded it from a web site.  Running this file 

will start the installation wizard, which will guide you through the process of installing the software on 

your computer. 

 

During installation you will be presented with a series of options.  If you are installing Personal Stock 

Monitor for the first time or are unsure about what to do, you should accept the default options.  If you are 

upgrading from a previous release, Personal Stock Monitor is designed to be upgraded in-place, so the 

installation program will attempt to install it in the same directory as the previous installation, and will 

make this the default option.  In most cases you will want to accept these options as-is.  Since some 

releases of the software will update the format of your data files, we recommend backing up your data files 

regularly and especially before installing upgrades. 

QuickStart 

  

The first time you run Personal Stock Monitor, it will automatically run the QuickStart Wizard.  This 

wizard will guide you through the initial steps in setting up Personal Stock Monitor for your Internet 

connection. 

Selecting Your Internet Connection 

Personal Stock Monitor supports connections through Dial-Up Networking as well as direct connections 

(such as FIOS, cable modem, DSL, DirectPC, LAN, etc.). The QuickStart Wizard will allow you to select 

the connection type that the software will use for retrieving quotes. 
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If you use a dial-up connection through a regular phone modem, or you have an internal ISDN modem that 

requires you to start Dial-Up Networking to connect to your Internet Service Provider (ISP), then you will 

want to configure Personal Stock Monitor to use the dial-up connection. 

 

If you have direct connection such as DSL or cable modem, or you are on the office network (LAN) or 

similar network, you should make sure that the dial-up settings are disabled.  When dial-up settings are 

disabled, Personal Stock Monitor assumes a direct connection and will not attempt to dial out.  This is also 

important in the case where you start out with a modem connection then switch to a broadband internet 

connection.  Just disable the dial-up option and Personal Stock Monitor should then work with your new 

faster connection. 

 

 To change the dial-up settings (outside of the QuickStart Wizard), select Options->Preferences->Dial-

Up. 

Proxy Configuration 

 

The trickiest part of the initial installation is often the "proxy" configuration.  A proxy, sometimes also 

known as a "proxy server" or "firewall", is a computer or device that sits on your network between your 

computer and the Internet (Figure 1).  It is known as a proxy because it communicates with the outside 

world on your behalf, and in such a position can implement access control and security policies of the 

organization, allowing you to hide computers from direct access by people on the Internet. 

 

If you have a direct dial-up connection, cable modem, DSL, or other type of direct connection, you 

probably do not need to worry about proxy configuration and can leave it turned off.  If you are in a 

corporate setting with a proxy or firewall, Personal Stock Monitor may be able to figure out the correct 

configuration if your web browser uses "manual proxy configuration".  If your browser uses "automatic 

proxy configuration," Personal Stock Monitor will not be able to determine the proxy settings by itself. 

In the case where the proxy configuration can not be automatically determined, there is one bit of technical 

information you will need to have: the host name or Internet Protocol (IP) address of the proxy host, and 

the port to use for the web proxy.  The host name is often something like "proxy.yourcompany.com", and 

the port number is often something like "80", "8000", or "8080".  If you are not sure what the proxy settings 

should be, please ask your network administrator for this information.  When you find out these settings, 

enter them into the proxy settings dialog in the Quick Start 3Wizard or in the Options->Preferences->Proxy 

dialog. 

 

After you enter the network settings, the Quick Start Wizard will give you the option of running a basic test 

to see if Personal Stock Monitor can retrieve Web pages from some sites on the Internet.  We recommend 

running this test before proceeding, because a failed test here could indicate that Personal Stock Monitor 

will not be able to retrieve quotes. 

Software Licensing 

Upon installation, Personal Stock Monitor will start operating in unlicensed mode if no license key has 

been entered.  In this mode, the software will be fully functional for a period of 30 days, after which time it 

will stop retrieving quotes.  This trial period should allow plenty of time for you to determine if the 

software meets your needs. 

 

Your Computer Proxy or Firewall

The

Internet

Figure 1 - Hypothetical network with proxy server 
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When you purchase a license, you will be sent an email with your User Name and License Key.  Both of 

these items must be entered exactly as in the email we send to you.  We also recommend keeping a copy of 

this email in a safe place so that you can re-enter this information if necessary at any point in the future.  In 

addition, your User Name and License Key will qualify you for discounts on future software upgrades. 

 

In order to fully enable the software, after your license key is entered you will be required to run through a 

quick activation procedure that will verify your license against our customer database.  After activation is 

completed you can continue using the software as before. 

 

Your license key entitles you to receive software upgrades at no additional charge for one year from the 

date of purchase.  This feature is based on the official release date of the software.  For example, if you 

purchase a license for Personal Stock Monitor Gold on January 1, 2010, then your free upgrade period runs 

through December 31, 2010.  The following then applies: 

 If we release Personal Stock Monitor Gold 10.0 on December 31, 2010, you would be able to upgrade 

to this release at no additional charge. 

 If we release Personal Stock Monitor Gold 10.0 on January 1, 2011, then you would need to purchase 

an upgrade license in order to use the new release. 

Software Upgrades 

 

One of the big concerns with software such as Personal Stock Monitor is support and distribution of 

updates.  Quote servers periodically change their data formats, and we release updates to Personal Stock 

Monitor so that it continues to work with those quote servers.  In addition, Personal Stock Monitor is 

updated fairly often simply because we are constantly working on improving it, as well as correcting any 

problems found in previous releases. 

 

In order to provide better service for our customers, we have created two features that help you determine 

when an upgrade is available and what changes were made.  First, there is a Personal Stock Monitor News 

feature that alerts you to any news or updates that may be available.  When Personal Stock Monitor first 

goes online, it automatically checks for any news and updates.  If news or updates are found, a yellow 

scrolling message containing a brief synopsis of the news will appear in the status bar of the Personal Stock 

Monitor window.  You can bring up the detailed information by clicking on the yellow the message.  While 

this feature is normally run automatically, you can also run it manually from the Online menu. 

  

Second, Personal Stock Monitor includes a tool called the Software Update Wizard that can check the 

software database on our Web server.  The Software Update Wizard can then download the updates and 

install them immediately.  You can run the Software Update Wizard at any time from the Help menu.  If for 

some reason the Software Update Wizard fails to properly download a release, you can always download 

the exact same software from the DTLink web site and install it manually. 

 

Personal Stock Monitor is designed to be upgraded in-place, which means that you can simply install any 

new versions into the same directory as the old version.  All program and license settings will be retained 

from the previous version, but we still recommend making backups between versions "just in case". 

Firewalls 

 

Since many computers now have personal firewall software installed, it is important that you have at least a 

basic understanding of how to use this software.  Most personal firewall software will work with Personal 

Stock Streamer without having to change any settings; in most cases you should get a prompt asking 

whether to allow Personal Stock Streamer to access the Internet.  However, sometimes a particular firewall 

program will not allow Personal Stock Streamer to access the Internet until you manually add it to the 

“allowed” list of applications. 

 

The network test that is part of the Quick Start Wizard, as mentioned above, is very useful in determining 

whether Personal Stock Streamer is being blocked from accessing the Internet.  If the network test fails, and 
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you have checked all other settings, then you should try temporarily disabling the firewall software to see if 

that could be the cause. 

 

Some firewall software also has a tendency to turn off the “allowed” status for upgraded applications, so if 

you were running an older version of Personal Stock Monitor, and you can not get updates after installing 

the new version, that is a common sign that the firewall is blocking the application.  In this case you may 

need to remove and re-add Personal Stock Monitor  to the allowed list of applications. 

  

3. Basic Concepts 
This section describes many of the terms and concepts used throughout the software and the rest of this 

User's Guide. 

The Tour Guide 

The Tour Guide is designed to demonstrate just a few of the most frequently used features in Personal 

Stock Monitor.  When you first run Personal Stock Monitor, the Tour Guide will appear in a window to the 

left of the main workspace.  You can also display the Tour Guide by selecting the Tour Guide command 

from the Help menu. 

 

Simply follow the directions in the tour guide to become familiar with the common functions available in 

Personal Stock Monitor. 

QuickLinks 

The QuickLinks in Personal Stock Monitor is kind of like Windows shortcuts: it provides a way to quickly 

perform a number of the common tasks in Personal Stock Monitor without having to look for the right 

command in the menus.  QuickLinks will appear after the Tour Guide is completed, or you can select the 

QuickLinks command from the Help menu. 

Online Help 

Context-sensitive online help is available throughout the application.  To bring up the online help, press the 

F1 key or the Help button if available in a particular dialog.  You can also select Help Topics from the Help 

menu to browse the help file.  

.stkx Files 

Personal Stock Monitor stores all of your portfolio data and the transaction register (as well as things like 

column and view settings) in files on your hard drive that have an ".stkx" file extension.  The software even 

includes two such sample files called Dow30.stkx and Sample Portfolio.stkx for demonstration purposes.  

These two files should not be used to store your personal portfolio data because they may be overwritten 

during a software upgrade if you're not careful.  Instead you should create a new file for your personal use 

and make regular backups so that you are protected against any unforeseen events such as hard disk 

crashes. 

 

Note for users of previous versions of Personal Stock Monitor: Personal Stock Monitor 

versions before 5.5 used the .stk file extension for its data files.  Stk files used a completely 

different format which is not compatible with .stkx files.  Personal Stock Monitor will read the 

older .stk files and will convert them to .stkx files, but Personal Stock Monitor versions before 5.5 

can not read .stkx files. 

Bookmarks 

Personal Stock Monitor Gold provides a flexible Internet bookmarks facility which allows you to store 

frequently used links to web sites with the software.  In addition, bookmarks can easily be dragged from a 

web browser and dropped in to Personal Stock Monitor. 
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There are three types of bookmarks: regular bookmarks, Jump Points, and Ticker Bookmarks.  The regular 

bookmarks function just like the bookmarks or favorites in your web browser in that they are available at 

any time.  Jump Points are special bookmarks that allow you to substitute the ticker symbol or ticker name 

as part of the bookmark.  This allows you to create bookmarks for things like discussion boards or research 

and have them automatically apply to all of your stocks.  Ticker Bookmarks are what we call "local" 

bookmarks, in that they are stored with a ticker symbol and can be used to save things like links to specific 

articles about the particular ticker.  More on bookmarks a little bit later. 

Ticker Symbols 

Each type of security (stock, mutual fund, option, etc.) is represented by a 

ticker symbol, which is often shorthand for the name of the security.  

Ticker symbols are used by financial services to display information about 

that security in a more compact way than writing out the entire name.   For 

example, the ticker symbol for Google is GOOG, for Microsoft it is MSFT, 

and for the Fidelity Magellan mutual fund it is FMAGX. 

 

Although the actual long name of the security is available for display 

purposes, Personal Stock Monitor uses ticker symbols as the main method 

of identifying securities.  If you do not know the ticker symbol for a 

particular security, you can use the Find Ticker by Name function (under the Account menu) to look it up. 

Cash Symbols 

You can also create a special type of ticker symbol to represent the uninvested balance in your account.  

This is called a cash symbol because it represents a cash or money market balance.  You can create a 

linked cash symbol which will be updated automatically by Personal Stock Monitor based on transactions 

posted directly to the cash symbol (such as deposit and interest) and transactions posted to ticker symbols 

in the same account (such as buy and sell).  There can be only one linked cash symbol in an account.  You 

can also create unlinked (or "Other") cash symbols to represent things such as a Certificate of Deposit 

(CD), and these will only be updated from transactions posted to the cash symbol.  There are no limits on 

the number of unlinked cash symbols you can create. 

Transaction Register 

The transaction register is the method used by Personal Stock Monitor to keep track of your current 

holdings, and based on that information to automatically calculate current value, change in value, and 

realized and unrealized gain.  Having a complete transaction history for all investments entered into 

Personal Stock Monitor is an essential step to having a complete picture of your portfolio. 

 

After you execute a trade with your broker, you should enter the information into the Personal Stock 

Monitor transaction register.  The software will calculate any gain, automatically adjust your uninvested 

funds balance to reflect the trade, and recalculate the current value of the investment based on that trade.  

You get immediate feedback on the effects of your trade without having to run separate reports. 

Since Personal Stock Monitor makes it easy to edit or delete transactions, this feature is also useful for 

"paper trading" with your investments. You can enter sample transactions to see how your portfolio 

would change based on a trade or sequence of trades, and see the results immediately reflected in all views. 

 

Figure 2 - Associating 

ticker symbols with 

company names 

Figure 3 - Example of transactions in the Transactions view 
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One important thing to keep in mind is that transactions in the transaction register are intimately linked to 

their ticker symbols, and therefore many of the things you do to ticker symbols will have an effect on the 

transactions that are posted to that ticker symbol.  For example, if you move a ticker symbol from one 

folder to another, any transactions that have been posted to that ticker symbol will move as well.   If you 

delete a ticker symbol, then the transactions would be deleted as well. As mentioned in the previous 

section, the value of linked cash symbols are calculated partly from transactions posted to ticker symbols, 

so doing something like moving or deleting a ticker symbol will affect the balance of related linked cash 

symbols.  It is therefore very important to remember these relationships when you are working with ticker 

symbols and transactions. 

Account Tabs 

Account tabs are the method used to group folders, ticker symbols, and transactions into one "view" (more 

on views later).  Account tabs may represent your actual brokerage accounts, or may simply be a list of 

tickers you want to watch. 

 

In Personal Stock Monitor Gold you can create an unlimited number of account tabs, each of which is 

shown at the bottom of the main window.  Changing the current account tab is as easy as clicking on it.  

You can even change the order of the tabs by dragging and dropping them into place! 

Folders 

Folders are used in Personal Stock Monitor to group related ticker symbols 

together within an account tab.  An example of this would be an Internet folder, 

which contained only Internet-related stocks.  Use of folders is completely 

optional, but there are some benefits to using folders, such as per-folder 

alerts, that you may want to take advantage of. 

Quote Servers 

Personal Stock Monitor uses the concept of a quote server to represent a location or company that provides 

stock quotes.  For example, Yahoo! has a quote server at http://quote.yahoo.com.  You can go to that 

location on the internet, enter a ticker symbol, and get a quote and news returned in your Web browser. 

 

Personal Stock Monitor includes support for many different quote servers, since some quote servers are 

better at some tasks than others or provide different types of quotes.  For example, the Yahoo! quote server 

previously mentioned provides delayed quotes and news headlines for US, Canada, and many international 

exchanges, while the TD AMERITRADE brokerage has a quote server that provides real-time quotes only 

for the US. 

 

If you have investments in multiple markets or different types of investments, you can get quotes for all of 

them in the same file because you can specify the quote server to use for each ticker symbol.  Therefore 

you can get a consolidated view of even a complex international portfolio. 

Integrated Trading 

If you have an account with our brokerage partner, you can execute live trades directly from within 

Personal Stock Monitor , without having to visit the brokerage web site.  Our brokerage partner also 

provides free real-time quotes and historical data for charts, so there is no additional cost for data as there 

would be with a subscription data service. 

Figure 5 ï sample 

folder with three 

tickers 

Figure 4 - Multiple account tabs 
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Delayed vs. Real-time, Snapshot vs. Streaming 

Different investing styles have different requirements for quotes, so data providers have created quote 

servers that provide different types of quotes.  There are two types of quotes, real-time and delayed, and 

two ways to deliver those quotes, snapshot and streaming.  The combination of these factors may influence 

your choice of data provider and the price you pay for your service. 

 

Delayed quotes represent trades that happened some number of minutes before you retrieved the quote, 

usually 15-20.  For example, if you get a delayed quote at noon from a 15-minute delayed quote server, the 

quote you get will be from a trade that happened at 11:45 or before.  The reason delayed quotes are often 

provided for free is that they are less relevant for making quick trades, since activities such as day trading 

rely on having the absolute latest prices.  However delayed quotes are still useful for following your 

investments over time and therefore should be adequate for the majority of investors. 

 

Real-time quotes represent trades that happened exactly at the time of the quote, so the numbers you get at 

noon are from the last trade that happened at noon or immediately before the time of the quote. 

 

Snapshot quotes are like taking a picture: you get a quote that is exactly what the last trade looked like at 

the point the trade happened.  In order to get quotes over time, you have to keep taking pictures at regular 

intervals even if no additional trades happened during that time.  

 

Streaming quotes are like watching a movie.  The pictures are displayed for you in rapid succession and all 

you have to do is sit back and watch.  Similarly, with streaming quotes you automatically get sent 

information about each trade as it happens (or 15-20 minutes delayed if you are getting streaming delayed 

quotes).  This method is more efficient than repeatedly getting snapshot quotes, but it also generally more 

expensive because of the timeliness of the data. 

Free vs. Subscription Quotes 

Personal Stock Monitor is independent of any particular quote server and only provides an easy and 

convenient way to access those servers and services.  While most of the quote servers supported in Personal 

Stock Monitor are free, some may require membership, subscription, or an account with the associated 

brokerage.  In those cases it is up to you to arrange for the account or subscription.  In the case of a paid 

subscription you would pay the quote provider directly, but you would be able to use the same login name 

and password to retrieve quotes with Personal Stock Monitor. 

Automatic Update Interval 

Since one of the main functions of Personal Stock Monitor is to automatically update your ticker symbols 

with the latest snapshot quotes, the automatic update interval can be described as the setting which 

regulates how often these updates happen.  When you first install Personal Stock Monitor, this interval is 

set to 15 minutes, but you can adjust this if you would like updates to happen more often or less often.  

Personal Stock Monitor keeps track of the last update for each ticker symbol, and will display in the status 

bar the time remaining until the next update. 

  

One important thing we will mention is that in order to reduce the load on the quote servers used by the 

software, the minimum value for the update interval is five minutes.  This does not in any way prevent you 

from getting immediate updates by selecting the Update Selected or Update All commands if you need an 

immediate quote.  It only makes Personal Stock Monitor a better neighbor on the Internet since it prevents 

overloading the quote servers to the point where no one can get quotes. 

 

Note that the update interval (and minimum update interval) does not apply for streaming quote servers 

since data is constantly arriving and does not have to be explicitly requested.  Also note that the update 

interval for our brokerage partner is fixed at 5 minutes regardless of the program setting, but you can still 

issue an Update All command to get quotes immediately. 
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4. Using Personal Stock Monitor 

The Main Window 

First let's go over the various parts of the main window.  Familiarizing yourself with the layout of the 

software will help you to perform the various tasks even faster. 

 

The menu bar contains all of the commands and options that are available in Personal Stock Monitor, 

roughly organized by category.  The toolbars contain what are essentially shortcuts to the most commonly 

used commands that are also available in the menu bar.  The info bar is where the Tour Guide and 

QuickLinks are displayed.  The main workspace is where all of your folders and ticker symbols will be 

displayed.  An account tab represents each account or watch list in the current file and allows you to easily 

switch between them by clicking on the desired tab.  The status bar displays status messages such as when 

data is being received or when a minor error occurs.  The next update timer shows a countdown 

(minutes:seconds) until the next scheduled update. 

 

We save last item in the picture above for last because it is special. The view selection tabs allow you to 

easily switch between the various "views" in Personal Stock Monitor: the Active Securities view, the 

Holdings view, the Transaction Register view, the News Headlines
1
 view, and the Reports view.  More on 

views a bit later, but keep these tabs in mind because you may be using them frequently. 

Menus and Toolbars 

The menu bar at the top of the window (File, Edit, etc.) is used to access all of the Personal Stock Monitor 

functions and commands.  Each menu is organized as follows according to the functions contained under it.  

The standard menus in Personal Stock Monitor are: 

 

 File - Commands that work with entire files, including New, Open, Save, Import, Export, and Print. 

 Edit - Commands that work on symbols in the current file, including Copy, Paste, and Find. 

 Online - Commands that are related to Personal Stock Monitor's use of the Internet, including Update 

All, Get Currency Table, and Bookmarks. 

 Account - Commands that are related to accounts, ticker symbols or folders, including Create New 

Account Tab, Find Ticker by Name, Clear Alert, Enter Transaction, and Chart. 

 View - Commands related to the view, including Sort, Layout, Portfolio Details, and Ticker Bar. 

 Options - Program options and settings. 

 Help - Online help and information. 

 

                                                           
1
 The News Headlines view and associated functions are available only in Personal Stock Monitor Gold. 

Info Bar 

Menu Bar 

Main 

Workspace 

Toolbar 

View Selection Tabs 

Next Update 

Timer 

Account Tab Status Bar 

Figure 6 The Main Window 
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Plug-ins and extensions to Personal Stock Monitor may create additional top-level menus, so this list may 

not be the complete list of menus you see on your screen. 

 

Some menu items have associated icons that are displayed next to the item.  These icons are the same as the 

icons displayed in the Toolbars, so instead of going through the menus to select a function, you can click 

the appropriate toolbar icon to perform the same task.  Therefore toolbars simply become a shortcut to 

using the menus. 

 

Many of the most common menu commands also have keyboard shortcuts, which are special key 

combinations that execute the related command.  If a keyboard shortcut is defined for a menu item, the key 

combination is displayed next to that menu item.  For example, the shortcut for the Find Ticker Symbol 

command under the Portfolio menu is Alt+L.  This means that if you press the Alt key and L key at the 

same time, Personal Stock Monitor will execute the Find Ticker Symbol command just like if you used the 

mouse to select it from the menu. 

Right-Click Menus 

Personal Stock Monitor also includes "right-click menus" (also known as context menus) which are pop-up 

menus that appear next to the mouse cursor when you click the right mouse button or press the context 

menu key on your keyboard.  The exact menu that is displayed can vary depending on where your mouse 

cursor is at the time you click the button, which is why these types of menus are often referred to as 

"context-sensitive".  Context menus are intended to be a quick way of accessing commonly used menu 

commands without having to go all the way up to the menu bar. 

Working with .stkx Files 

When you first start using Personal Stock Monitor, you should create a new file to store your portfolio data.  

Using the Dow30.stkx or Sample Portfolio.stkx files included with Personal Stock Monitor is not 

recommended because when you upgrade the software they may be overwritten by the installer. 

 

 To create a new .stkx file, select File->New. 

 To open an existing .stkx file, select File->Open. 

 Several of the most recently used files will be listed at the bottom of the File menu.  You can switch 

between them easily by selecting the appropriate menu item. 

Workspace Views 

There are several different "views" in Personal Stock Monitor which help you see different parts of your 

data in different ways.  The built-in views include Home, Active Securities, Current Holdings, Transaction 

Register, Live Order History, News Headlines, and Reports.  Additional views may be created through 

software extensions known as plug-ins. You can switch between the views using the view selection tabs 

above the main workspace or by selecting the appropriate item under the View menu. 

  

What is in the different views? 

 

The Home view is the software home page, and shows news and important information about the software, 

plus links to tutorials. 

 

The Active Securities view is probably the view you will be looking at most of the time.  In this view you 

create ticker symbols that you want to watch, and maybe some folders to organize the tickers into groups.  

This view contains only active ticker symbols and folders, which are those that you are currently watching 

Figure 7 - Menu command with icon and keyboard shortcut 
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and/or updating.  To remove a ticker symbol from this view you must either mark it inactive or delete it, 

both of which will be described later. 

  

The Current Holdings view displays only the ticker symbols in which you have an open position, and it 

optionally breaks out current holdings by lot.  This view is useful as a portfolio summary view for your 

current holdings. 

 

The Transaction Register view shows your complete trading history broken out into individual transactions.  

The transaction records are used to calculate current holdings as well as realized and unrealized gains, and 

to produce reports. 

 

The Live Order History view shows your order history when linked to your brokerage account, and allows 

you to manage your live trades. 

 

The News Headlines view
*
 shows headlines received from the quote servers, organized by folder and ticker 

symbol.  It highlights the latest news to help you make your investment decisions with as much information 

as possible. 

 

The Reports view displays any reports generated from the current portfolio data.  Available reports include 

a capital gains summary, transaction detail, and value by asset class
*
.  Additional reports may be available 

through extensions. 

How the Views are Related 

Imagine a single building that has many windows.  Looking in any one of the windows allows you to see a 

different part of the building or a different perspective, but it is still the same building.  In a similar way, 

the workspace views just give you a different perspective of your document, but it is still the same 

document and the same data. 

 

Consider a ticker symbol that has one purchase transaction but no sale transaction.  This ticker symbol is 

said to have an open position.  The symbol would be displayed in the Active Securities view because it is 

an active ticker and in the Current Holdings view because it has an open position.  It would also be 

displayed in the Transaction Register view because there is one transaction posted to it.  If headlines were 

retrieved for that ticker, then the ticker and the headlines would also be displayed in the News Headlines 

view.  Also consider a ticker symbol that had news headlines but no transactions.  This ticker symbol 

would only be displayed in the Active Securities and News Headlines view. 

 

This concept is extremely important when you consider how ticker symbols can be changed.  Since 

transactions are directly linked to their ticker symbols, if you moved a ticker symbol from one folder to 

another the transactions would move as well, and this change would be reflected in the Holdings and 

Transaction Register views.  News headlines behave similarly, so the News Headlines view would also be 

changed to reflect the new location of the ticker symbol. 

Customizing the Views 

Personal Stock Monitor gathers a lot of data, and there are several options available that can make it easier 

to manage the flood and make it easier to read.  By default, Personal Stock Monitor enables alternating 

color bars in the main workspace, which makes reading across the window easier.  The default color here is 

gray, but you can easily change that in the preferences.  There is also an option to display grid lines, which 

can help reading up and across the window.  You can even set the background color on individual ticker 

symbols to "color-code" different types of symbols and make them easier to find in a long list.  But the best 

customization feature allows you to change which columns are displayed on the screen so you only see the 

columns you want. 

 

                                                           
*
 Available only in the Gold edition 
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Although by default you are shown several columns on the 

screen, this is only a subset of the information that is 

available.  We just didn't want to overload you with 

information right away, because Personal Stock Monitor can 

display dozens of columns of information!  The views are 

completely configurable using the Arrange Columns 

command or the equivalent button on the toolbar, which will 

bring up a dialog in which you can select which columns 

appear on the screen as well as the order in which they 

appear. 

 

 To enable grid lines or alternating color bars or to 

change the color of the bars, select Options-

>Preferences->Display. 

 To set the background color on ticker symbols, select 

the symbols, then select Portfolio->Ticker 

Properties->Advanced. 

 To select which columns are displayed, select View->Layout->Arrange Columns. 

View Layouts 

As you can see in Figure 8, there are many columns to choose from, which allows you to select just the 

information that you are interested in.  Even better, you are not limited to just one column configuration.  

Personal Stock Monitor includes a feature which lets you create named groups of column configurations 

called view layouts.  Using the Edit All Layouts command under the View menu, you can create multiple 

view layouts, each with a different column configuration. A view layout can be selected into any account 

tab in your file, and if you switch away from that account tab it will automatically switch back to that view 

layout when you come back. 

 

Using a toolbar button you can easily switch between your view layouts to quickly see different sets of 

columns.  This allows you to concentrate on the columns you want to see most, but quickly view other 

columns when necessary. 

 

 To create or edit view layouts, select View->Layout->Edit All Layouts. 

 To change to a different view layout, select the layout by name from the View->Layout menu. 

Custom Columns 

With Personal Stock Monitor Gold, you can create custom memo or expression columns that will appear in 

your Active Securities and Current Holdings views. 

 

Memo columns are simple columns that can contain comments or other information.  You can edit the 

content of memo columns by first highlighting the ticker, then clicking in the memo column.  This will 

display an edit box which will allow you to type in the information. 

 

Expression columns calculate their value using a mathematical expression.  You can not directly edit the 

content of these columns except to edit the mathematical expression that calculates the value. 

 

 To create or edit custom columns, select Options->Preferences->Custom Columns. 

 

 For expression columns, the field names in the expression must be exactly the same as the names on 

the columns, including capitalization, and they must be entered in quotes.  For example, if you want to 

use the Price field in an expression, you must enter it as “Price”, because “price” will not work.  The 

only exception is field with spaces, in which case the spaces are optional so for example “% Change” 

can also be entered as “%Change” and “52 Week High” can also be entered as “52WeekHigh”. 

 

The following are valid operators and types for expressions: 

Figure 8 The Arrange Columns dialog 
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Operator Description 

<, >, <=, >=, == Standard comparison operators: less than, greater than, 

less than or equals, greater than or equals, exactly 

equals. 

&&, || Boolean AND and OR operators 

(, ) Paretheses are used to control order of evaluation by 

creating sub-expressions. 

abs() Function that returns the absolute value of its argument 

+, -, /, * Standard mathematical operators: add, subtract, divide, 

multiply. 

 

 For example, you can create an expression column that displays the difference between the current 

high value and price: High – Price 

 

When you create custom columns, they are added to the available columns in the Active Securities and 

Current Holdings views, but they are not automatically visible.  You will need to use the View->Layout-

>Arrange Columns command to show your custom columns. 

Multiple Account Tabs 

With Personal Stock Monitor Gold you can create multiple account tabs in a single document and easily 

switch between them.  This is very useful if you have accounts at different brokerages, or if you are 

managing portfolios for other people.  Summary data such as totals are calculated separately for each 

account tab so you will know exactly how each account is doing. 

 

The tabs at the bottom of the main window represent the accounts in the current document.  The tab 

representing the currently displayed account tab has a white background, while all others have a gray 

background. 

 

 To create a new account tab, select Account->Create New Account Tab. 

 To rename the current account tab, select Account->Rename Account Tab. 

 To view a different account, click on its tab at the bottom of the main window. 

 You can switch between the first ten account tabs in your document by pressing the Alt key and a 

number key.  For example, pressing Alt+1 will switch you to the first account tab, and pressing Alt+0 

will switch you to the tenth account tab. 

 You can rearrange account tabs by using your mouse to drag the account tab to the desired location in 

the list. 

Account Tab Properties 

Each account tab can have its own currency
*
, quote server, and update settings.  For example you may wish 

to have an account tab whose ticker symbols are never updated, or updated only from a particular quote 

server, displayed in a different currency than the other account tabs. 

 

 To edit the settings for an account tab, including currency and update settings, select Account-

>Account Tab Properties. 

Account Tab Alerts 

Personal Stock Monitor Gold has an additional option in the Account Tab Properties dialog that allows you 

to set alerts for entire account tab that are applied to all tickers contained inside.  The details of setting 

alerts are described later in this document. 

                                                           
*
 Only available in the Gold edition. 
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Working with Folders 

Each account tab can contain just ticker symbols if you like, but you can also create folders to group ticker 

symbols together. You can create any number of folders to group your ticker symbols into categories.  For 

example, you can create an Internet folder for all of your Internet stocks, or a Retail folder for all retail 

stocks.  This will help you see the performance of any group very quickly. In the Sample Portfolio.stkx file 

that is included with Personal Stock Monitor, there are several such folders, each for different types of 

stocks such as Internet, e-commerce, and so on.  Similarly, you can create folders in your own account tabs 

to group stocks for organizational purposes.  Folders can also be created inside other folders, so you can 

have as many levels of folders as you need. 

 

 To create a folder, select Account->New->Folder. 

 To collapse or expand a folder, double-click on it, or right-click and select Collapse or Expand. 

 To create a ticker symbol or a folder inside a given folder, first select the folder then select the new 

ticker symbol command (see below) or new folder command. 

 To move a ticker symbol into or out of a folder, select the ticker symbol and drag it to the desired 

location. 

 To move a ticker symbol under a folder without placing it into the folder (using drag and drop), hold 

down the control key when dropping the symbol into its place. 

Folder Properties 

Each folder can also have its own update and quote server settings similar to the options available for 

account tabs.  That is to say that you can set individual folders to update from different quote servers or at 

different intervals. 

 

 To change the update settings for a folder, select Account->Folder Properties. 

Folder Alerts 

Personal Stock Monitor Gold has an additional option in the Folder Properties dialog that allows you to set 

alerts for the entire folder.  These alerts are valid for all sub-folders and ticker symbols contained in the 

folder.  The details regarding setting up folder alerts are described later in this document. 

Working with Ticker Symbols 

Ticker symbols are used to represent the security itself to the quote server.  Personal Stock Monitor also 

uses ticker symbols to stock your transactions, alerts, historical data, and view settings related to the 

security. 

 

 To create a new ticker symbol, select Account->Add New Ticker. 

 

When manually entering ticker symbols it is important to remember to set the ticker type properly because 

some quote servers require special handling for certain ticker types in order to properly retrieve quotes. The 

default ticker type is Stock, but if you are tracking mutual funds, options, or other types of tickers you 

should make sure to change this option appropriately.  If you forget to set the ticker type while creating the 

symbol you can still change it using the ticker properties dialog. 

Ticker Properties 

The ticker symbol properties dialog allows you to change various settings that are specific to the ticker 

symbol.  You can use this dialog to set the ticker type, assign asset classes, set alerts, enter or edit 

transactions, enter notes, override global settings, and perform other operations related to the ticker symbol. 

 

 To display the ticker symbol properties dialog, select the ticker symbol then select Portfolio->Ticker 

Properties. 
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Finding Ticker Symbols 

One thing to keep in mind is that each quote server has its particular requirements for ticker symbols.  

Since most quote servers accept symbols in all capital  letters, Personal Stock Monitor by default converts 

any ticker symbol you enter to use all capital letters.  This "Force Symbols to Upper Case" option is a 

requirement because Personal Stock Monitor needs to know exactly what symbol to look for when the data 

is returned by the quote server, so the symbol entered must exactly match the symbol returned by the quote 

server. 

 

Similarly, if a quote server requires that the ticker symbol is mixed-case, which for example can happen 

with different stock classes, you can disable the “Force Symbols to Upper Case” option so you can enter 

mixed-case ticker symbols such as BRKb or NOKa. 

 

There may be times when a particular ticker symbol is only available from a particular quote server.  Since 

Personal Stock Monitor has the ability to talk to different quote servers at the same time, you can override 

the quote server setting for any ticker symbol so that it is retrieved only from the server you choose. 

 

If you do not know the ticker symbol, the easiest way to locate the correct one is to use the Find Ticker 

Symbol command.  Since most of the supported quote servers include a ticker lookup feature, Personal 

Stock Monitor can take advantage of this to find your ticker symbols and add them to your list. 

 

 To search for a ticker symbol, select Account->Find Ticker by Name. 

 To disable the Force Symbols to Upper Case option, select Options->Preferences->General. 

 To tie a ticker symbol to a particular quote server, select Account->Ticker Properties->Advanced. 

Arranging Ticker Symbols 

The most common way to arrange ticker symbols inside an account tab or folder is to sort the entire list on 

a specified column.  For example, if you wanted to have your list sorted on the "% Change" field so that 

tickers are shown in descending order of their percent change for the day, you could click on the "% 

Change" column header.  An indicator arrow will appear in the header indicating the direction of the sort, 

ascending or descending.  If you want to reverse the order of the sort, click on the "% Change" column 

again.  The benefit of having your list sorted this way is that the tickers are automatically re-sorted after a 

quote update so the sort order is always maintained. 

 

Another way to arrange ticker symbols and folders is by dragging and dropping them into place.  This 

works well if you want to move ticker symbols between different folders, or if you want to have a specific 

order for your symbols.  Note that dragging and dropping has the effect of turning off automatic sorting, so 

the tickers will not be re-sorted after quote updates. 

 

 To sort on a column, click on its column header.  To reverse the sort direction, click on it again. 

 To define secondary sort on a different column, right-click on its column header.  No indicator arrow 

will appear, but the sort will be in place. 

 To move a ticker symbol or folder, click and hold the mouse on it, then drag it into place.  To drag it 

below another folder without moving it inside the folder, hold the Ctrl key when you let go of the 

mouse button. 

 To move a ticker symbol or folder between account tabs or folders without affecting the sort order, 

select Account->Move to.. and select the destination folder.  

Active vs. Inactive Tickers 

Since transactions are directly linked to their ticker symbols, when you delete a ticker symbol you also 

delete any associated transactions.  Since deleting transactions permanently affects your records, there 

needs to be a way to delete the symbol but keep all transactions that have been recorded for that ticker 

symbol.  The solution to this problem is the concept of active and inactive ticker symbols. 

 

When you create ticker symbols they are automatically active.  That is, they are displayed in all relevant 

views and they are updated normally along with the rest of the tickers. 
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When you no longer want to track a ticker but you want to keep its transaction history, you can mark the 

ticker inactive.  Inactive tickers are not updated automatically, not displayed in the Active Securities or 

News Headlines views, and they are only displayed in the Current Holdings view if there is an open 

position on them.  When the position is closed out the tickers disappears from all views, but the 

transactions are retained and can be viewed in the Transactions view. 

 

Note that inactive tickers are not deleted from the document, which means that if you mark a ticker inactive 

you can re-activate it at a later time.  To do this, first select View->Inactive Tickers to display all tickers 

that have been marked inactive, then use the Mark Active command to change them back to active tickers. 

 

 To delete a ticker symbol and its transactions, select Account->Delete. 

 To mark a ticker or folder inactive, select Account->Mark Inactive. 

 To mark a ticker or folder active, select Account->Mark Active. 

 To view all inactive tickers and folders, select View->Inactive Tickers. 

Changing (Renaming) a Ticker Symbol 

Sometimes a ticker symbol can change, such as when a company changes its name or gets listed on a 

different exchange.  Personal Stock Monitor does not automatically track ticker symbol changes, but you 

should still change the ticker symbol in order for Personal Stock Monitor to be able to update quotes 

correctly.  Personal Stock Monitor provides a command explicitly for this purpose, and it ensures that all 

transactions that were posted to the old ticker symbol are properly retained under the new ticker symbol. 

 

 To change a ticker symbol, select Account->Rename or press the F2 key. 

Asset Classes 

Asset classes are another way of organizing your ticker symbols.  They are basically categories, with names 

such as Stocks, Bonds, International Stocks, Large Cap Stocks, and so on.  Using asset classes is 

completely optional, but in some countries you may find it convenient to assign asset classes to your ticker 

symbols for reporting purposes. For stocks it is sufficient to assign a single asset class, but for mutual funds 

that consist of a mixture of different securities you can assign multiple asset classes on a percentage basis. 

 

As an example of the usefulness of asset classes, consider this example.  If you are limited to having only 

25% of your portfolio value in international investments, as long as you assign your international 

investments to the International asset class, you can run a report of value by asset class to make sure you 

are under the limit. 

 

 To assign an asset class to a ticker symbol, select the ticker symbol then select Account->Ticker 

Properties.  The asset class assignment is under the General page. 

Currency Conversion 

If you are working with international investments, then the currency conversion feature in Personal Stock 

Monitor Gold may be useful to you.  An international quote server such as Yahoo! UK will provide quotes 

in different currencies depending on the exchange where the ticker is listed.  For example, a stock on the 

London exchange may be quoted in British Pence while a stock on the Paris exchange may be quoted in 

French Francs.  If you are in Germany, you may want to have everything displayed for you in Deutsche 

Marks.  Personal Stock Monitor can be set up to do this conversion if the proper options are selected. 

 

The basic premise of doing currency conversion in Personal Stock Monitor is that everything is always 

converted from the quote currency (the currency in which the quote is retrieved) into the display 

currency.  The quote currency is set for each individual ticker symbol, while the display currency is set for 

all ticker symbols but can also be set for each account tab, in which case the account tab setting overrides 

the global setting.  No conversion is applied to any ticker symbol whose quote currency is not set. 
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In the example given above, you would set the quote currency for the London stock to GBN (Pence) and 

the quote currency of the Paris stock to FRF (Francs).   Then you would set the display currency to DEM 

(Deutsche Marks) and Personal Stock Monitor would do the currency conversion automatically. 

 

 To set the global display currency, select Options->Preferences->Display. 

 To set the display currency for a account tab, select the account tab, then select Account->Account Tab 

Properties. 

 To set the quote currency for a ticker symbol, select Account->Ticker Properties->Advanced. 

 To update the currency conversion ratios, select Online->Update Currency Table. 

Working with the Transaction Register 

The transaction register is used by Personal Stock Monitor to keep you informed about the current value of 

your portfolio, as well as to track past performance.  As mentioned before, you should enter transactions 

into the transaction register after a trade is completed, so that your position information is updated and any 

unrealized or realized gain can be calculated.  If you use the integrated trading support, then transactions 

can be easily entered into the transaction register from the Live Order History tab. 

 

Personal Stock Monitor supports a range of transaction types that can be used to track your progress.  These 

include not only the standard buy and sell transactions, but also transactions for dividend reinvestment, 

margin interest, and cashless stock transfers into and out of your accounts.  

 

 

There are several additional transaction types available for options: 

 

 

 To enter a transaction for a ticker symbol from the Active Securities, Current Holdings, or News 

Headlines view, select the ticker symbol then select Account->Transaction Register->New 

Transaction. 

 To enter a transaction for an existing ticker symbol from the Transaction Register view, select a 

previous transaction for that ticker symbol then select Account->Transaction Register->New 

Transaction. 

Transaction Type Description 

Buy Normal purchase transaction. 

Sell Normal sale transaction. 

Sell Short Short sale transaction. 

Buy to Cover Buy to cover a short sale. 

Split Stock split or reverse split. 

Dividend Cash dividend; Can also be money market account dividend. 

Reinvest Div Dividend reinvested for stock. 

Transfer In Transfer of shares into the account from an outside source. 

Transfer Out Transfer of shares out of the account. 

MiscExpense Miscellaneous expense or account maintenance charges. 

MiscIncome Miscellaneous income. 

Deposit Cash deposit. 

Withdraw Cash withdrawal. 

Interest Cash interest. 

Margin Int Margin interest charges paid on a margin account balance. 

Return of Capital Return of Capital 

Transaction Type Description 

Buy to Open Buy options to establish a long position 

Sell to Close Sell options to close out a long position. 

Sell to Open Sell options to establish a short position. 

Buy to Close Buy options to close out a short position. 
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 To cut a transaction from a ticker symbol to the clipboard, select the ticker symbol then select 

Account->Ticker Properties->Transactions, then select the transaction and press the Cut button. 

 To paste a transaction from the clipboard, select the ticker symbol then select Account->Ticker 

Properties->Transactions, then press the Paste button. 

Partial Sales with Multiple Lots 

By default, Personal Stock Monitor calculates gains from sales in FIFO order.  This means that if you hold 

multiple lots of a stock and you sell some shares, the software will calculate the gain on the assumption that 

you sold the first lot first, the second lot second, and so on. 

 

Personal Stock Monitor also supports selecting individual lots for transactions by using the Select Lots 

button in the transaction entry dialog.  This button is enabled when you have multiple lots available to work 

with, and will allow you to select the lots in the order in which they should be applied to the transaction, so 

that your gain and remaining shares are properly calculated. 

Average Cost Basis 

Some countries require that gains are calculated using the average cost basis instead of FIFO.  In Personal 

Stock Monitor, you can select this option on the Options->Preferences->Display page.  This is a global 

option and affects all gain calculations in all account tabs. 

Transaction Currency 

Personal Stock Monitor Gold allows you to specify the currency and conversion ratio for individual 

transactions on the date of the transaction in order to maintain an accurate representation of your portfolio.  

If you are using the currency conversion function, you should make sure to select the appropriate currency 

and enter the conversion ratio from your brokerage statement.  If you do not enter this information, 

currency conversion will be done at the current conversion rate, which will cause the transaction value to 

fluctuate whenever you update the currency table. 

Selling Short 

Personal Stock Monitor includes a Sell Short transaction type.   In the Active Securities and Current 

Holdings views, a short position will be indicated when the number of shares listed in the Shares column is 

negative.  To cover a short transaction, enter a Buy to Cover transaction for that ticker. 

Stock Splits 

Personal Stock Monitor handles splits like any other transaction.  Splits are not detected automatically by 

the software, so if you are watching or holding a stock that splits then you should enter the split transaction 

on the date that the stock starts trading at the split price.  Personal Stock Monitor will ask you whether you 

want to adjust the historical data files, which you should do in order to ensure that the charts look correct.  

Entering a split transaction will also ensure that your current holdings are adjusted appropriately so that the 

number of shares and basis are correct for the gain calculations.  For example a 2-for-1 split would be 

entered as a Split transaction with 2 in the New Shares box and 1 in the Old Shares box. 

 

The only tricky part of handling splits is what to do when you have more than one instance of a particular 

ticker symbol.  In this case we recommend entering the split for each instance (or use copy and paste to 

insert it) but only adjusting the historical data files once. 

Reverse Splits 

Sometime a company will issue a reverse split for a particular reason, such as to increase its share price. 

Reverse split transactions in Personal Stock Monitor are entered the same way as regular split transactions, 

but you just have to make sure that you put the correct numbers in the New Shares and Old Shares boxes.  

For example, a company issuing a 1-for-10 reverse split (for every 10 shares you currently own, you will 

own only one share after the split) would be entered as a Split transaction with a 1 in the New Shares box 

and a 10 in the Old Shares box. 
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Creating Account Tabs to Represent Brokerage Accounts 

To track your current holdings and the value of your brokerage accounts, you can use Personal Stock 

Monitor account tabs.  The recommended procedure is to create an account tab for each of your brokerage 

accounts, create cash symbols to represent your cash or money market balance, create the appropriate ticker 

symbols in each account, and then enter transaction histories.  If you have an account with one of our 

brokerage partners, you may have the option of downloading this information automatically, or if your 

transaction history is in a program that can export transactions to a QIF file, then Personal Stock Monitor 

can import those files to save you time entering transactions. 

 

The benefit of having your transaction history in Personal Stock Monitor is that you can easily track your 

account value and gains.  Personal Stock Monitor will display unrealized gains in the Gain column of the 

Active Securities view, and realized gains in the Gain column of the Transaction Register view.  The 

current value is displayed in the Total Value column.  The total under the Change column is the net change 

in value of your account for the current day, based on the Change value and the number of shares of each 

item. 

 

 To create an account tab to represent an trading account, select Account->Create New Account 

Tab. 

 To create a cash symbol, select Account->New->Cash Symbol. 

 To create a ticker symbol, select Account->Add New Ticker. 

 To enter a transaction, select the symbol, then select Account->Transaction Register->New 

Transaction. 

 To display the complete transaction register, select View->Transaction Register. 

 To display the active securities list after displaying the transaction register, select View->Active 

Securities. 

 To import a QIF file, select File->Import, and select QIF as the file type. 

Adjusting the Cash Balance 

When you create a linked cash symbol, it may not be immediately obvious how the cash balance is 

calculated.  Recall that linked cash symbols reflect the transactions posted all of the ticker symbols in the 

same account, so even if you create a cash symbol with a zero balance it will have a balance based on the 

transactions for other ticker symbols in that account. 

 

For example, say you have an account in which you created a ticker symbol IBM and purchased 100 shares 

at 100 dollars each (and no commission), for a total cost of 10,000.  If you later create a linked cash symbol 

in that account  with a zero balance, its balance will automatically be recalculated to be -10,000 because of  

the IBM purchase transaction.  If the real cash balance in that account is 2,000, then you will need to enter 

an adjustment deposit of 12,000 in order for the displayed balance to be correct.  However, from that point 

on, the balance should always match your statements as long as you enter all transactions posted to that 

account. 

Figure 9: Sample folder with tickers and cash balance 
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Working with Charts 

Personal Stock Monitor includes a charting package for intraday and historical charts.  You can have 

multiple charts open at the same time.  

  

 To display a chart, select the ticker, then select Account->Chart->Intraday or Historical. 

 To display charts for several tickers at once, hold down the Ctrl key while clicking on the 

additional symbols, then select the Intraday or Historical command. 

 To change between line, candle, and OHLC charts, right-click on the chart and select from the 

Chart Type menu. 

 To change between log and linear Y axis on the main chart, right-click on the chart and select 

from the Chart Scale menu. 

 To change other settings on the chart, or to add indicators such as moving averages, MACD, and 

other technical indicators, press the Edit button. 

The Historical Database 

The charts depend on having historical data available.  Some quote services do not provide any historical 

data at all.  Some quote services, such as TD AMERITRADE and DTN IQFeed, provide both end of day 

and intraday data from their servers, so in most cases you could request a historical or intraday chart for 

any available ticker symbol, and Personal Stock Monitor would be able to retrieve the data from the data 

services.  Some services such as Yahoo, provide only end of day data, but not intraday data, so you would 

be able to display historical charts but not intraday charts. 

 

The way that Personal Stock Monitor gets around this problem is to store historical and intraday data in a 

database as it is collected.  Then, when you need to call up a chart, the software can always get the data 

from the database. 

Interpreting Candlestick Charts 

Personal Stock Monitor supports several different types of charts, including candlestick, line and OHLC.  

Candlestick charts in particular can be a little confusing because the candle can be red or black, hollow or 

filled.  This leaves some people wondering what each of these states means, so we wanted to document it 

here: 

 

If the close < previous close, the candle is red. 

If the close >= previous close, the candle is black. 

If the close < open, the candle is filled in the candle color. 

If the close >= open, the candle is hollow. 

Zooming 

Personal Stock Monitor charts provide a zooming capability that lets you focus on a particular range of 

dates or times.   Historical charts can be zoomed down to a single day, and intraday charts can be zoomed 

down to a one hour. 

 

To begin the zoom, hold down the Ctrl key on the keyboard and click the mouse at the location on the chart 

where you want to start the zoom.  While holding down the mouse button, move the mouse to the location 

on the chart where you want to end the zoom.  This will highlight the segment of the chart that will be 

zoomed.  When you release the mouse button, the chart will be zoomed to that segment and the Duration 

box will be set to Custom.  You can also zoom in further on any segment of a zoomed chart.  To un-zoom 

the chart, right-click inside the chart and select Un-Zoom, or select a different duration from the Duration 

box. 

Line Drawing and Annotations 

Personal Stock Monitor charts support several types of annotations, including Fibonacci retracements, that 

allow you to visualize and highlight trends and help you make better trading decisions. 
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 To select the type of annotation to draw, press the Select Annotation Type button in the chart 

settings panel. 

 To draw an annotation on the chart, click on the location where you want to begin, and while 

holding down the mouse button move the mouse to the location where you want to end.  When 

you release the mouse button the annotation will be drawn. 

 If you are drawing a line annotation and you want to make the line perfectly vertical or horizontal, 

hold down the Shift key while drawing the line. 

 To set Fibonacci retracements, right-click on the line where you want to show retracements and 

select the Fibonacci retracements option. 

Additional Options 

There are several options available in the chart context (right-click) menu that are not available in the top-

level menus.  These include Remove High and Low Ticks, and Close All Charts, as well as options to copy 

the current chart to the clipboard or save it to disk.  To see all of the options and available commands, click 

the right mouse button inside the chart. 

Chart Profiles 

The group of trends and indicators (such as SMA, MACD, and so on) that are displayed at the same time 

are called a chart profile.  If you want to quickly switch between different sets of indicators to see different 

views of the chart data, you can define additional chart profiles.  Once the profiles are defined with the 

desired indicators, you can easily select the profile you wish to see from the drop list at the bottom of the 

chart window. 

 

 To create and edit chart profiles, press the Edit button in the chart window.s 

Setting Alerts 

Personal Stock Monitor includes one of the most powerful alert systems on the market.  It will keep you 

informed of important events on ticker symbols in any portfolio or folder based on criteria you choose.  

Alerts can be set on a number of fields, including Price, Bid, Ask, Change, Volume, and others.  The alert 

function is flexible, too: You can set as many alerts for each ticker symbol or folder as you want, and each 

alert can trigger a different action.  You can even set alerts on Total lines, so you are notified when your 

total portfolio value crosses a threshold. 

Alert Types 

Alerts consist of two parts: a condition and an action.  A condition is a mathematical expression such as 

"Price > 24.25" which is tested after each quote update.  When the expression evaluates to true or a non-

zero value, the associated action is triggered.  The only exception to this is the News alert, which is defined 

as a Boolean condition which evaluates to true when there is new news available.  Personal Stock Monitor 

includes a selection of possible actions that can be taken as a result of a condition being met: 

 

Action Description 

None Indicate that an alert was triggered with a yellow bell next to the alert 

attribute. 

Beep Speaker Play the standard system beep. 

Flash Window Flash the toolbar button and/or task bar icon if the main program window is 

not in focus. 

Bring to Top Bring the main program window to the foreground if it is minimized or 

obscured by other windows. 

Play Sound Play a sound, which must be a .wav file. 

Set Color Change the cell color. 

Run Program Run another program. 

Send Email * Send an email message containing the alert information. 

Send to 

NotePager Pro * 

Send the alert to a running copy of NotePager Pro software, which allows 

advanced paging, email and SMS messaging.  For more information visit 
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http://www.notepager.com. 

* Only available in Personal Stock Monitor Gold. 

 

When an alert is set on a field such as Price, a little black bell will appear next to the Price field for that 

ticker symbol.  (You can prevent it from appearing by changing the Alert Set Indicators option under 

Options->Preferences->Display.)  When the alert is triggered, a yellow bell will appear next to the field, 

and a yellow alert triangle will appear in the first column on the screen.  This ensures that even if you set an 

alert on a field that is currently not visible, you will still see that there is an alert present by the yellow 

triangle next to the symbol. 

Setting Alerts 

One thing to note with regard to alerts is that external alerts (run program, email, and pager) will not work 

unless the Suspend External Alerts option is turned off under the Options menu.  This option is there to 

easily allow you to suspend these alerts while you are at your desk but resume them when you go away. 

 

 To configure pager or email settings, select Options->Preferences->Services. 

 To create alerts on ticker symbols, select the symbol, then select Account->Ticker Properties->Alerts. 

 To create alerts on folders, select the folder, then select Account->Folder Properties->Alerts.  (Personal 

Stock Monitor Gold only.) 

 To create alerts on account tabs, select the account tab, then select Account->Account Tab Properties-

>Alerts. (Personal Stock Monitor Gold only.) 

 To define a news alert, select the News field when creating your alert.  You can read more about 

setting alerts in the next section. 

 To create alert actions, select Account->Alerts->Edit Alert Actions, or press the "…" button while 

editing the alert. 

 To enable or disable the Suspend External Alerts option, select the Options menu. 

 

There is one important thing to be aware of when you define folder and account tab alerts:  Folder and 

account tab alerts are never actually triggered for the folder or account tab itself.  What happens when you 

define this type of alert is that each ticker symbol is tested for the alert condition, and when the condition is 

met the alert is copied into the ticker symbol and triggered.  What this means is that if you look at the alert 

list for that ticker symbol, you will see a copy of the alert from the folder or account tab as if it was defined 

for the ticker symbol all along.  Alerts that are copied this way are shown in the list in gray instead of black 

to differentiate them from the regular alerts defined on that ticker.  These copied alerts will be 

automatically deleted from the list when you reset the alert by selecting the Clear Alerts command as 

described below, but you can also manually delete them if you like. 

Alert Expressions 

Personal Stock Monitor Gold includes support for free-form alert expressions which allow you to specify 

even more powerful alert conditions which can include multiple fields and values.  Expression alerts can 

also use Boolean operators and functions. 

 

 To create alert conditions using free-form expressions, then select the Free-form Expression box when 

editing the alert condition. 

 The field names in the expression must be exactly the same as the names on the columns, including 

capitalization, and they must be entered in quotes.  For example, if you want to use the Price field in an 

expression, you must enter it as “Price”, because “price” will not work.  The only exception is field 

with spaces, in which case the spaces are optional so for example “% Change” can also be entered as 

“%Change” and “52 Week High” can also be entered as “52WeekHigh”. 

 

The following are valid operators and types for expressions: 

 

Operator Description 

<, >, <=, >=, == Standard comparison operators: less than, greater than, 
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less than or equals, greater than or equals, exactly 

equals. 

&&, || Boolean AND and OR operators 

(, ) Paretheses are used to control order of evaluation by 

creating sub-expressions. 

abs() Function that returns the absolute value of its argument 

+, -, /, * Standard mathematical operators: add, subtract, divide, 

multiply. 

 

Some examples: 

 Price of your stock goes up by more than 10% and the volume is more than ten million shares: 

("%Change" > 10) && ("Volume" > 1000000) 

 Price of your stock goes up by more than 10% or your unrealized gain is more than 50%: ("%Change" 

> 10) || ("%Gain" > 50) 

 Price of your stock goes up or down by more than 10%: abs("%Change") > 10 

Clearing Alerts 

When an alert is triggered it must be cleared before it can be triggered again.  The only exception to this is 

a news alert, which is always triggered on any new headlines.  Clearing the alert indicates to Personal Stock 

Monitor that you have received it, which is especially important for alerts which you have set to repeat 

periodically because it is the only way to stop the repetition. 

 

 To clear a single alert, select the ticker then select Portfolio->Alerts->Clear Alert. 

 To clear all alerts for all tickers, select Portfolio->Alerts->Clear All Alerts. 

Sticky Alerts 

Normally alerts will automatically clear if the condition that caused them is no longer true.  Sticky alerts do 

not automatically clear.  For example if you have an alert on price > 10 and price goes above 10 for a 

moment and triggers the alert, if the price falls back below 10 then without a sticky alert it will 

automatically clear, but with a sticky alert it will continue to show in the alert state. 

 

5. Getting Quotes 

Quote Servers and Ticker Symbols 

Because Personal Stock Monitor supports so many different quote services, one of the problems that comes 

up is that they potentially use different ticker symbols to represent the same stock or fund . While this is not 

a problem for most US stocks, we start to run into trouble with index symbols, share classes, and most non-

US exchanges.  For example, even for US exchanges some quote servers use the dollar sign '$' as a prefix 

for index symbols, while Yahoo uses the circumflex '^'.  Further complicating the matter is that each quote 

server may call the same index by a different name, so you have ticker symbols such as $INDU, ^DJI, and 

DJIND all representing the same thing, in this case the Dow Jones Industrial Average.  This means that if 

you ever switch quote servers you may have to adjust any ticker symbols you have that have different 

formats on your new quote server. 

 

Personal Stock Monitor does some mapping of ticker symbols, in particular for the most popular indeces, 

so for example you could enter ^DJI into your list and it would work for both Yahoo and Other quote 

services for which the translation is supported.  However there is no general solution to the problem, so it is 

best to pick a quote server that has the data you need, and do not switch quote servers unless it is necessary. 

Options Tickers 

As of February, 2010, all data services have begun transition to a new options ticker format as specified by 

the Options Clearing Corporation (OCC).  However, since each data service is free to decide on their own 

internal options ticker format, instead of a common format that would work across data services, Personal 
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Stock Monitor uses its own options ticker format that is easy to work with for our customers, and easy for 

the software to translate to the appropriate internal ticker symbol for the particular data service. The new 

ticker symbol format is as follows: 

 

[Option Root] [Expiration Month] [Expiration Day] [Expiration Year] [Put/Call] [Strike Price] 

 

The expiration day is optional.  For example, the ticker symbol for a January 2010 Call option for MSFT 

with a strike price of 22.5 would be written as 

 

MSQ Feb 2010 Call 22.5 

 

When you enter this ticker into the software, Personal Stock Monitor will automatically calculate the 

expiration day and rewrite the ticker as 

 

MSQ Feb 20 2010 Call 22.5 

 

This new ticker will automatically be translated to the correct internal symbol for the quote services that 

support this new format.  As of the revision date of this guide, the quote services that are supported with 

this new ticker symbol are TD AMERITRADE, DTN IQFeed, and Yahoo. 

 

One thing to keep in mind is that Personal Stock Monitor can only calculate the expiration day for options 

that follow the “Saturday after the third Friday” rule.  For options that don‟t follow this rule, such as some 

index options, you must specify the correct expiration day, or you will not be able to get quotes for that 

ticker. 

 

For quote services that have not transitioned to the new ticker symbol format, or are not explicitly 

supported for automatic conversion by Personal Stock Monitor, you will have to use their native options 

ticker format until such time as support can be added. 

AutoQuote 

One of the main reasons for using a program such as Personal Stock Monitor in the first place is that it will 

automatically retrieve quotes for you.  We call this feature AutoQuote.  You can configure Personal Stock 

Monitor to retrieve quotes at any interval between 5 and 999 minutes, and it will automatically connect to 

the Internet and retrieve the quotes. 

 

By default, Personal Stock Monitor is configured to update your ticker symbols every 15 minutes.  You can 

change this interval for all ticker symbols, for an individual ticker, for a folder, or for an account tab. 

 

 To set the default update interval for all ticker symbols, select Options->Preferences->Updates. 

 To set the update interval for an account tab, select Account->Account Tab Properties->Advanced. 

 To set the update interval for a folder, select Account->Folder Properties->Advanced. 

 To configure how PSM uses Dial-Up Networking, select Options->Preferences->Dial-Up. 

 To select the default quote server, select Options->Preferences->Network or select the server from the 

drop-down list on the toolbar. 

Multiple Connections 

Personal Stock Monitor can also take advantage of high speed Internet service by issuing more than one 

request at the same time.  (We use the terms "request" and "connection" interchangeably.) While we 

recommend that dial-up modem users keep the number of simultaneous connections between 1 and 3, you 

can set this number as high as 9 in order to take advantage of a fast DSL, cable modem, or office T1 line 

for example. 

 

 To increase the number of simultaneous requests, select Options->Preferences->Network. 

 

Personal Stock Monitor will only try to open the additional connections if allowed by the quote service. 
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Manual Updates 

Occasionally you may have a ticker symbol that is not listed on any of the exchanges, but you still want to 

keep track of it.  Because Personal Stock Monitor allows you to create any ticker symbol you wish, you can 

still create it in your list and update the price manually.  The current value and gain will be recalculated 

based on the price you enter.  This feature is also useful for playing "what-if" with your prices because it 

allows you to see what your holdings would be worth at a particular price point. 

 

 To manually set the price for a ticker symbol, select Account->Set Ticker Price. 

The Scrolling Ticker Bar 

The scrolling ticker bar is a special window that continually scrolls quotes and news across your screen, 

just like on TV!  With the ticker bar, you can keep an eye on everything while doing other work, because 

the ticker bar window stays on your screen as long as Personal Stock Monitor is running. 

 

While the ticker bar is running, different colors represent different events such as positive change, negative 

change, and if an alert is active for the ticker symbol.  You can even get detailed information on any ticker 

that scrolls by with one or two clicks. 

  

 To display the ticker bar, select View->Ticker Bar. 

 To change ticker bar preferences, select Options->Preferences->Ticker Bar. 

 To get information on a ticker, move the mouse so that the ticker is outlined, then click the left mouse 

button to display ticker properties, or click the right mouse button for additional options such as news. 

 To manually scroll the ticker bar right or left, hold down the Ctrl key while clicking inside the ticker 

bar, then move the mouse right or left. 

 To drag the ticker bar to a different location, hold down the Alt key while clicking inside the ticker bar, 

then drag the window to the desired location. 
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6. News and Research 

Getting News 

Wouldn‟t it be nice if you could easily get the latest news for your investments?
1
  Knowing what is going 

on with your investments is essential to making decisions.  Several of the quote servers (such as Yahoo) 

provide news headlines for ticker symbols retrieved from those quote servers.  Personal Stock Monitor can 

display the latest news headlines posted for your tickers, and if it is the current day the news will be 

highlighted to call your attention to it.  There is also a separate News Headlines view. 

 

 To enable the news date and news headline columns, select View->Layout->Arrange Columns and 

select the News and News Headline columns into the visible columns. 

 

Note that Personal Stock Monitor will only retrieve the news dates and news headlines if you use one of the 

quote servers that provide news headlines with their quotes
2
. 

 

When you are in the Active Securities view and enable the News column, it displays the date of the last 

known news item.  If there is unread news for the ticker, the date or time is displayed in bold type.  If there 

is unread news for the current day, the date is drawn in red.  You can double-click on the date or time to 

display the most recent unread news item in your browser. 

 

When you are in the News Headlines view, just double click on a news headline to see the full story in your 

web browser.  You can even define alerts that notify you when a new item is posted to the news for your 

tickers, and define an alert action that sends the latest headline to your email or pager! 

 

Each news item will have a date or time next to it to indicate when it was retrieved a time indicates that it 

was retrieved at that time during the current day, and a date indicates that it was retrieved some time on that 

date.  Times for the current day's items are colored red to draw attention to them, while previous days dates 

are colored black.  Unread news items are drawn in bold text, while read news items are drawn in regular 

(thin) text. 

 

 To mark an item or range of items read without actually reading them, first select the items then right-

click on the list and select Mark as Read. 

  

If you use a quote server that is not supported for news headlines, you can still easily retrieve news stories 

for many stocks and display them in your browser.  This function will display the page from the quote 

server which contains headlines for your ticker symbol, but the news will not be placed into the News 

Headlines list and you will not be alerted to new news posted to these pages. 

  

 To display news, select the symbol, then select Account->Research->News. 

 To select the quote server which will be used for displaying news in your web browser, select Options-

>Preferences->Network. 

 

Optionally, Personal Stock Monitor can use Internet Explorer as an internal browser and have the news 

stories appear right inside of the main Personal Stock Monitor window.  This option is enabled by default 

on new installations. 

 

 To change the option to use Internet Explorer as the internal browser, select Options->Preferences-

>Network->Browser Preferences. 

                                                           
1
 The News column, News Headline column, and the News Headline view are only available in Personal 

Stock Monitor Gold. 
2
 As of this writing, these quote servers are Yahoo!, Yahoo! UK, Yahoo! Australia, Yahoo! Singapore, 

GTrade, and Quicken.com, but this list is subject to change. 
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Research 

There is a wealth of research information available on the Internet, so much so that the biggest problem is 

keeping track of it all.  Personal Stock Monitor has several ways to help you keep track of what you find so 

that you have it when you need to refer to it later. 

Bookmarks
*
 

Personal Stock Monitor Gold includes a bookmarks (or "favorites") feature that allows you to keep track of 

important web sites.  The software comes preloaded with a selection of sites from quote server web sites to 

research and other informational sites.  These bookmarks are available at all times within the program, and 

you can easily edit this list as you wish to add your own sites. 

 

One interesting trick for fast access of bookmarks is to use mnemonic key assignments.  When you create 

the bookmark, you can indicate that you want quick access to that bookmark from a particular key by 

putting an ampersand (&) before that letter.  For example, if there was a bookmark that was called “Motley 

Fool” and you wanted quick access to it through the "F" key, you would create the bookmark as "Motley 

&Fool".  When you select the bookmark menu that contains this bookmark, the "F" will be underlined and 

you can quickly select the "Motley Fool" bookmark by pressing the "F" key when that menu is displayed.  

This can save you a little work because for lists with many bookmarks you no longer have to scroll down to 

the correct bookmark with your mouse.  This key assignment trick also works for ticker bookmarks and 

jump points as described below. 

 

 To jump to a bookmark location (URL), select the bookmark from the Online->Bookmarks menu, or 

from the bookmarks pop-up window. 

 To bring up the bookmarks pop-up window or to edit the bookmarks list, select Online->Bookmarks-

>Edit Bookmarks. 

Ticker Bookmarks
* 

Ticker bookmarks are special bookmarks that are stored for a particular symbol instead of globally for the 

entire program.  The reason this feature is so useful is that it allows you to store specific links to news or 

articles for a particular symbol without cluttering the bookmark list.  You can then recall these items at any 

time with just a couple clicks. 

 

 To jump to a ticker bookmark, right-click on the ticker symbol, then select Ticker Bookmarks, then 

select your desired bookmark.  You can also jump to a bookmark by selecting Account->Ticker 

Bookmarks, and the bookmark after selecting the symbol. 

 To edit ticker bookmarks, select the ticker symbol then select Account->Ticker Properties-

>Bookmarks. 

Jump Points
* 

Jump Points are special global bookmarks that allow you to substitute the ticker symbol or name for part of 

the bookmark.  This allows you to create a single bookmark that will be valid for all ticker symbols, such as 

a link to a chat room or a research site where the only parameter you need is the ticker symbol or name.  

This eliminates the need to create special bookmarks for each ticker symbol. 

 

Jump Points are contained in the global bookmark list under a special folder called Jump Points. Although 

you can call your own Jump Points whatever you like, you must not rename the Jump Points folder or else 

it will lose its special properties and will not be recognized properly by the software.  Of course if you ever 

rename it by mistake you can always change the name back to Jump Points and everything will return to 

normal. 

 

                                                           
*
 Available only in the Gold edition of Personal Stock Monitor. 
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You can create your own Jump Points by putting a special tag into the location or URL of the bookmark.  

When you later select the Jump Point, Personal Stock Monitor will substitute the tag with the correct item 

from the ticker symbol before passing the URL to your browser.  The valid tags that are currently available 

are listed in the table below. 

 

Tag Description 

$(Symbol) Full ticker symbol. 

$(Symbol[0]) The first character of the ticker symbol. 

$(Name) The name of the ticker symbol. 

 

For example, to go to the Yahoo quote page for a particular symbol, create a jump point as 

http://finance.yahoo.com/q?s=$(Symbol)&d=t.  When this Jump Point is selected Personal Stock Monitor 

will substitute the ticker symbol for the $(Symbol) tag and take you to the correct quote page. 

 

 To jump through a Jump Point, select the ticker symbol then select the appropriate Jump Point from 

the Online->Bookmarks->Jump Points menu, the bookmarks list, or the right-click menu. 

 To edit the Jump Point list, select Online->Bookmarks->Edit Bookmarks to bring up the Bookmarks 

window and edit the bookmarks in the Jump Points folder. 

Drag and Drop Bookmarks
* 

Drag and drop is widespread in the implementation of the Bookmarks system, and is designed to make 

creating and managing bookmarks quite easy.  The following drag and drop operations are supported: 

 

 You can drop bookmarks into the Bookmarks window or on top of a ticker symbol.  In the latter case 

the bookmarks will become a ticker bookmark and will be stored with the ticker symbol. 

 Drag and drop bookmarks from Internet Explorer 3.02 or later or Netscape 4.0 or later. 

 Drag links from any OLE-compatible application.  Even if you happen to be in a Word document that 

has a piece of text such as http://www.something.com in it, you can highlight that text and drag that 

text into the Bookmarks window or into a ticker symbol to create a bookmark. 

 Drag headlines from the News Headlines view in Personal Stock Monitor to a ticker symbol, browser 

window, or another OLE-compatible application. 

 In the embedded browser window in Personal Stock Monitor, you can drag a link from within the 

browser window to create a bookmark for that link, or you can drag the little bookmark icon next to the 

URL to create a bookmark for the current page. 

 

7. Trading 
 

Personal Stock Monitor includes a secure trading interface that allows you to quickly and easily place, edit, 

and cancel live orders with our brokerage trading partners, and without having to log into the brokerage 

web site.  The trading interface is tightly integrated into the Personal Stock Streamer user interface, so it‟s 

easy to place trades from almost anywhere in the system. 

Getting Started 

To use the trading features in the software, you can select your brokerage as the preferred quote service 

from the service selection dialog, or you will need to log into your brokerage account from the Live Order 

History tab. 

 

Enter your username and password for the brokerage account you wish to trade in.  It is recommended that 

if you have more than one account, such as a regular trading account and an IRA account, that you use the 

brokerage web site to link these accounts if possible so that you can access them under a single login.  This 

will also allow you to track orders and trade through Personal Stock Streamer in any of your linked 

accounts, without having to log into each account separately. 

                                                           
*
 Available only in the Gold edition of Personal Stock Monitor. 
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Associated Account Tabs 

Once you are logged into your trading account, you will need to associate an account tab in your Personal 

Stock Monitor document with a trading account.  This can be done by selecting the Live Order History tab 

and pressing the Associate Account button.  When a trading account is associated with an account tab, the 

brokerage icon will appear next to the name of the account tab at the bottom of the Personal Stock Monitor 

window. 

 

By default you can only place trades from an account tab that is associated with a trading account, although 

this option can be disabled in the program preferences to allow trading from an unassociated account tab. 

Live Order History 

The Live Order History tab displays as much trading history for the current trading account as is available 

from the brokerage, including any currently open orders.  Filled orders can be entered as transactions in 

your Personal Stock Streamer transaction register by right-clicking on the order and selecting Create in 

Transaction Register.  Filled orders that have not been entered in the transaction register will appear in bold 

type in the order history list. 

Placing Orders 

To place an order, right click on the ticker symbol and select the Trade command.  Fill in all of the 

parameters for your trade.  If you select the Sell or Buy to Cover command, the number of shares will 

automatically be filled in based on your current holdings.  After you are done with your order, press the 

Verify Order button to continue.  This gives you a chance to make sure that your order is correct before 

pressing the Place Order button. 

 

You can also reuse any previous order from the Live Order History tab.  Select right click->reuse order and 

the Trade dialog will appear with the order parameters filled in.  You can change any of the order 

parameters before submitting the order. 

Login/Logout 

You can log out of the trading service any time by selecting the Logout command under the Actions menu 

in the Live Order History tab. 

 

If you are using a different service for your streaming data, you can manually log into your brokerage 

account for trading by selecting the Login command under the Actions menu in the Live Order History tab. 

Basic Commands 

To place a live order:  Right-click->Trade or press the Trade button above the ticker list 

 

To view an option chain for a stock: Right-click->Option chain 

 

To add one or more tickers from the option chain window to the portfolio: Right-click->Add to Portfolio 

   or 

Drag and drop from the Option Chain window into your ticker list at the desired location 

 

To associate a portfolio with a brokerage account:  Portfolio->Portfolio Properties 

   then 

select associated brokerage and account from drop list. 

 

In the Live Order History window, you can filter out filled, expired, and canceled order by selecting "show 

only open and pending orders" from the Actions menu. 

 

You can reuse any order in the Live Order History window by right-clicking on it and selecting Reuse 

Order. 
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You can edit an open order by selecting Edit Order.  This will submit an edit request to the brokerage, and 

will attempt to replace the open order with your new parameters.  Note: not all orders are editable.  The 

Edit Order menu command will only be enabled for orders that the brokerage has indicated are editable.  

Note: Your order may still be filled while you are editing it.  In that case the edit request will be rejected by 

the brokerage. 

 

You can cancel an open order by selecting Cancel Order.  Note: not all orders are cancelable.  The Cancel 

Order menu command will only be enabled for open orders that the brokerage has indicated are cancelable.  

Note: Your order may still be filled by the brokerage while you are trying to cancel it.  In that case the 

cancel request will be rejected by the brokerage. 

 

Only filled transactions can be moved from the order history to your transaction register.  To enter an order 

as a transaction into your transaction register, right-click on the order, select Create in Transaction Register.  

Note that some brokerage partners may not specify the commission or miscellaneous fees through their 

interface, so you can enter these into the transaction dialog before saving the transaction to the transaction 

register. 

 

8. Reports 
 

Personal Stock Monitor includes a report view that allows you to get a summary of things like capital gains 

over the course of a year or a list of transactions between two dates.  Reports are always displayed for the 

currently selected account tab. 

 

 To select the Reports view, select View->Reports. 

 

When you select the Reports view, a filter bar will appear which will allow you to select the report type and 

date range.  The screen is automatically updated when you change the filter. 

Next to the report type drop-down, there is a Report Properties button ( ) which can be used to change 

any additional settings for the report.  Not all reports will have additional settings, so this button will only 

be enabled when supported by the selected report. 

 

Several reports are included with the software as extensions: 

 

 Capital Gains Report – a basic capital gains report that shows realized gains and losses for the 

current account tab, excluding dividends and interest. 

 Extended Capital Gains Report – a capital gains report that includes dividends and interest, as well 

as other income and expenses from the transaction register. 

 Consolidated Summary report – a report that shows realized gains and losses for all account tabs 

in the current file.  Gains and losses for the same ticker are summarized into a single line. 

 Consolidated Capital Gains report – a capital gains report that shows realized gains and losses for 

all account tabs in the current file.  Each lot is shown on its own line. 

 Consolidated Current Positions report – a report that shows all current open positions for all 

account tabs in the current file. 

 

Additional reports may be available for free download 

 

 To see the list of additional reports that may be available select Tools->Extensions, then press the 

Get More Extensions button. 

 

9. Importing and Exporting Data 
 

Personal Stock Monitor can import and export several types of ASCII-format data, including QIF and 

Metastock ASCII format. 
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The simplest format for importing and exporting is known as the comma-delimited or comma-separated 

value (CSV) format.  CSV files contain lists of items such as ticker symbols and prices separated by 

commas.  For example: 

 MSFT,90.0,50.0,70.0 

 

You may also have a longer CSV file that just contains a list of ticker symbols you wish to import: 

 MSFT 

 DELL 

 IBM 

 AOL 

 RHAT 

 

Personal Stock Monitor can easily import this list to create ticker symbols in the current account tab. 

 

You can also export your current data to a variety of formats (including CSV) for exchange with other 

software or for use in your spreadsheets. 

 

 To import a text file, select File->Import. 

 To export a text file, select File->Export. 

 

There are also several special formats supported by Personal Stock Monitor which help you exchange data 

with programs such as Quicken and Metastock. 

Importing from Quicken 

You can export your transactions from Quicken as a QIF file (select File->Export in Quicken) then use the 

File->Import command in Personal Stock Monitor to import the portfolio data.  This procedure will work 

with most other software that exports QIF files, such as Microsoft Money. 

 If you are starting with a blank portfolio in Personal Stock Monitor, you should first create a file that 

contains your list of securities by checking the Security Lists option in the Quicken export dialog, and 

importing this file into Personal Stock Monitor.  

 To export the transactions from Quicken, select the Transactions option in the Quicken export dialog. 

 To import a QIF file into Personal Stock Monitor, select File->Import and select the QIF option in the 

Files of Type field. 

Exporting to Quicken 

To export a QIF file from Personal Stock Monitor, first select View->Transactions.  If you wish to only 

export a subset of transactions, select the transactions you wish to export.  Then select File->Export, and 

make sure that QIF is the type selected in the Files of Type field.  Enter the file name and press OK to 

export. 

 

The exported QIF files can also be imported into most software that supports the QIF standard, such as 

Microsoft Money. 

Exporting to Metastock 

Metastock is one of the most widely used technical analysis programs available, and the Metastock ASCII 

data format has become a de-facto supported standard among other technical analysis programs as well. 

Personal Stock Monitor supports exporting current and historical data to this format so that you can use the 

data for your analysis. 

 

 To export current or historical data in Metastock format, select the ticker symbols for which you wish 

to export data, then select File->Export and select one of the Metastock options, then enter the file 

name and press Save. 

 Note that the Metastock historical data export is only available in the Gold edition of Personal Stock 

Monitor. 
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Exporting Transactions to CSV 

For those of you who still use a program such as Excel for analysis or reporting, you can export a list of 

transactions to a comma separated value (CSV) file.  Importing transactions from a CSV file is currently 

not supported. 

 

 To export transactions to a CSV file, select View->Transactions, select the transactions you wish to 

export, then select File->Export.  Make sure to select the CSV option in the Save as Type field before 

pressing the Save button. 

Importing Transactions from CSV 

For those of you who have a list of transactions you wish to import from CSV files, you can do this if the 

CSV file has at least the following fields: date, price, shares, and type.  The type field must match one of 

the transaction types in the software: Buy, Sell, Sell Short, Buy to Cover, and so on. 

 

 To set up the import, switch to the Transaction Register tab.  Select File->Import, then use the Select 

Fields button to select the fields that are present in your CSV file.  Once this is done, you can select the 

file from the file browser and press the Open button. 

 

 

10. Plug-ins 
 

Among the many features that Personal Stock Monitor already offers, you can add even more functionality 

through Personal Stock Monitor plug-ins.  These plug-ins are similar to those you may see for your web 

browser: they provide specific enhancements to the existing software or add support for additional features.  

Personal Stock Monitor provides an open architecture that allows developers to write a wide variety of 

plug-ins in order to meet your changing needs. 

 

Plug-ins may be downloaded directly from the developer's web site, the DTLink web site, and some 

developers may choose to make their plug-ins available through the Software Update Wizard.  Plug-ins 

downloaded through the Software Update Wizard may be installed automatically, but plug-ins downloaded 

directly from the developer's web site must be installed by going through the plug-in management page 

inside Personal Stock Monitor. 

 

 To install, uninstall, or configure plug-ins, select Options->Preferences->Plug-ins. 

 For a list of currently available plug-ins, visit our web site at http://www.personalstockmonitor.com. 

 

DTLink Software offers a Software Development Kit (SDK) for developers interested in writing plug-ins 

for Personal Stock Monitor.  For additional information, visit the Developers section of our web site at 

http://www.personalstockmonitor.com. 

 

11. Extending and Integrating Personal Stock Monitor 
 

In addition to plug-ins, which are fairly complicated to write, Personal Stock Monitor can also be extended 

using script languages such as VBScript and JScript, as well as automated from Excel and other similar 

programs. 

The Object Model 

Personal Stock Monitor has a complete scripting object model that is used both to extend and integrate the 

application.  Through this object model, you can control the application from an external script or another 

program, as well as extend it by adding menu commands, reports, windows, and other functions. 

 

Full object model documentation is beyond the scope of this document, but is available in the Developers 

section of the personalstockmonitor.com web site. 

http://www.personalstockmonitor.com/
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Extensions 

Rather than integration with another application, script extensions are specifically designed to provide 

additional functionality in the software.  Extensions are loaded when you start Personal Stock Monitor, and 

can be managed through the Tools->Extensions window.  Several extensions are bundled with the software, 

and additional extensions can be downloaded through the same window. 

 

Additional documentation, as well as source code for sample extensions, is available in the Developers 

section of the personalstockmonitor.com web site. 

 

12. Linking to Excel 

Dynamic Data Exchange (DDE) 

DDE is a way of dynamically linking different applications and allowing them to exchange data and 

commands.  Personal Stock Monitor Gold includes a plug-in that implements DDE to allow dynamic 

linking of Personal Stock Monitor Gold to client applications such as Microsoft Excel.  When a link is 

established, data is automatically updated in the client application whenever it is updated in Personal Stock 

Monitor. 

 

For applications such as Microsoft Excel, you can establish a dynamic link to one or more ticker symbols 

simply by dragging and dropping the desired symbols from Personal Stock Monitor into your Excel 

spreadsheet.  Exactly which fields are linked can be configured in the program preferences. 

 

 To configure DDE, select Options->Preferences->Data Exchange. 

 

Personal Stock Monitor is pre-configured for Microsoft Excel and Corel Quattro Pro, but you can also enter 

a custom syntax for other applications. 

 

Note: For applications such as Excel and Quattro Pro, some parts of the DDE link have to be put in quotes 

or apostrophes for them to work properly.  Therefore you will need to make sure that the names of account 

tabs and folders that contain the tickers you are dragging do not have any quotes or apostrophes. 

Topic and Item Syntax 

If your client application does not accept drag and drop, you can manually establish DDE connections by 

entering the appropriate connection string into your application. 

 

DDE syntax normally consists of three parts: a server, a topic, and an item.  These are often expressed as 

server |topic!item.  To clarify, this is the DDE server name, followed by a vertical bar, followed by the 

topic, followed by an exclamation point, and finally followed by the item.  However different applications 

have different ways of expressing DDE links, so you should check the help for your particular application 

to determine the exact syntax. 

 

For Personal Stock Monitor, the server name is “PSM”.  In the general case, the topic is the ticker symbol 

and the item is the name of the field (such as Price, % Change, or Volume).  The exceptions for the topic 

syntax occur when you have multiple identical ticker symbols within your document.  Although you can 

specify just the ticker symbol as the topic, Personal Stock Monitor will link to the first one it finds, so in 

order to link to a specific ticker symbol in a particular account tab or folder, you have to specify the full 

“path” of the ticker symbol. 

 

The ticker “path” consists of a series of account tab and folder names, separated by backslashes, that tell 

Personal Stock Monitor exactly which ticker you are referring to.  If the path contains any spaces or non-

letter characters, you may have to surround the entire path with single or double quotes (again this depends 

on your application).  For our example example we will use Microsoft Excel, which requires single quotes.  
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So if you have a ticker YHOO in a subfolder called Internet in a folder called Watch List in an account tab 

called My Account, the full path of the ticker would be „My Account\Watch List\Internet\YHOO‟.  This 

single-quote rule also applies to fields such as „% Change‟. 

 

Given the example above, the full DDE syntax to access the %Change field is as follows: 

 PSM|‟My Account\Watch List\Internet\YHOO‟!‟% Change‟ 

The System Topic 

Some DDE clients support use of what is known as a System topic, which allows the client to enumerate 

the available topics and items in order to allow you to select them from a list.  Although Personal Stock 

Monitor does support the System topic, it is very limited in function.  Because Personal Stock Monitor is a 

dynamic system, the topic and item lists are not pre-generated and therefore can not be fully enumerated by 

clients.  What will happen is that the System topic will only allow you to enumerate those topics and items 

to which you have already established links, therefore for those DDE clients that support this function, you 

will not be able to browse all available topics and items ahead of time. 

Excel DDE Syntax 

The DDE syntax for Excel is a formula with the format “=server|topic!item”, following the topic and item 

syntax above.  Constructing and placing this formula in a cell will establish the connection to a running 

copy of Personal Stock Monitor. 

 

The file Sample Portfolio.xls (included with Personal Stock Monitor) contains an example of linking to the 

Sample Portfolio.stkx file.  For additional help on creating DDE links in Excel, see the DDE topic in the 

Excel on-line help. 

  

13. Backup and Restore 
 

To prevent data loss due to unforeseen circumstances, we recommend frequent backups of your important 

data.  Personal Stock Monitor makes this process very easy by providing a backup facility right in the 

software.  You can back up the current .stkx file and historical data files in one step.  Restoring your data 

after a crash is just as easy. 

 

 To make a backup of the current .stkx file and historical data files, select File->Backup. 

 To restore an .stkx file or historical data from a backup file, select File->Restore. 

 

The files that Personal Stock Monitor generates for a backup are created with a .stkxbak file extension, but 

the files are actually zip-compatible archives and can be read with standard zip-compatible utilities such as 

WinZip. 

 

The backup and restore feature is also useful for moving files between computers, since all of the necessary 

files are packed into the .stkxbak file.  Just create a backup on one computer, copy the file over to the 

second computer, and restore from the backup file.  Note this backup mechanism does not make a copy of 

the Personal Stock Monitor program itself; you will need to manually install Personal Stock Monitor on 

your new computer. 
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14. Getting Help 
 

Finally, if you have trouble figuring out what a dialog or menu item does, there are a couple of things you 

can do.  Personal Stock Monitor includes a full context-sensitive online help system which explains all of 

the dialogs and commands. 

 

 If you need help on a dialog, you can press the Help button or F1, which will bring up the online help. 

 If you need help on a menu item, highlight the menu item then press F1. 

 To bring up the help contents, select Help->Help Contents. 

 

We also offer Web and email support to our customers through our Web site at 

http://www.personalstockmonitor.com. 

 

 To contact Technical Support by email, select Help->Technical Support->Contact Technical Support. 

 

Thanks for using Personal Stock Monitor! 

 

http://www.dtlink.com/
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A. Column and Field Reference 
 

Personal Stock Monitor can only display the fields that are available from the quote server or can be 

calculated from the available data.  Please keep in mind that many quote servers do not provide data for all 

fields even though Personal Stock Monitor allows their display.  When a field is not available at the quote 

server, it will be displayed with a zero or blank value on the screen. 

 

For the "Active Securities" and "Current Holdings" views: 

 

Symbol The ticker symbol 

Type The type of ticker symbol (Stock, Mutual Fund, Option, Money Market, Index, 

Bond, Future, Commodity) 

Name The long name of the ticker symbol, could be company name or description 

Price Last quoted price 

Change Change in price from market open. 

Note: The total under the Change column is the same as the total for the Value 

Change column.  This is just a quick way of seeing the change in value if you 

don't want to see the Value Change column all of the time. 

High High price for the day 

Low Low price for the day 

Volume Number of shares traded 

Last Update Date and time this quote was last updated by PSM, in local time 

Open Price of ticker at market open 

Open Int. Open Interest, only applicable for options 

Avg. Vol Average volume 

Bid Price a market maker is willing to pay for one share  

Ask Price at which a market maker is willing to sell one share 

Spread Difference between Bid and Ask 

Bid x Ask Size of Bid and Ask 

Prev Close Price of ticker at close of market the previous day 

52 Week High Highest closing price over the past year 

52 Week Low Lowest closing price over the past year 

News Date or time of last news item found for this ticker.  For quote servers which 

may only provide the date but not the time for news items, PSM uses the time at 

which the news was retrieved. 

 

If the time or date is shown in bold type, it means there are unread news items 

for this ticker.  If it is shown in red, it means that there are unread news items 

for the current day.  Double-clicking on this field will display the most recent 

unread news item in your web browser. 

News Headline Last posted headline for this ticker 

Last Trade Time of last recorded trade 

Last Size Size of last recorded trade 

Exchange Exchange on which this ticker trades 

P/E Ratio Price to earnings ratio 

EPS Reported Earnings Per Shares 

Dividend Annual dividend 

Yield Yield 

Mkt. Cap Market Capitalization 

Shares Number of shares currently held 

Avg. Basis Average price paid for the shares held, excluding commissions 

Avg. Cost Average price paid for the shares held, including commissions 

Total Basis Total price paid for the shares held, excluding commissions 

Total Comm. Total commissions paid for the shares held 
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Total Cost Total price paid for the shares held, including commissions 

Share Value Current value of shares determined by price (or bid/ask if that option is 

selected) multiplied by number of shares.  This column will not be filled in for 

cash symbols. 

Total Value Same as share value, except value of cash symbols will be included. 

Value Change Net change in value for the current day. 

Gain Current unrealized gain, the difference between the share value and total cost.  

Note that this does not include the anticipated commission to be incurred for 

closing out the position. 

Avg. Age Average age (in months) of the shares held. 

Currency Currency in which this ticker is quoted at the quote server. 

Server Quote server selected for this ticker.  If "Default" then the global setting is used. 

 

For the "Transactions" view: 

 

Type Type of transaction 

Avg./Share Average cost per share 

Gain Realized gain for the transaction 

Total Total value of transaction 

 

For the "Headlines" view: 

 

News Headline The text of the headline 

Source If provided, the source of the news headline. 
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B. Quote Server Reference 
 

This is intended to be a summary of the quote servers and exchanges they cover, along with any special 

features or requirements.  The actual list of quote servers inside the software may differ. 

  

Name Home Page Notes 

TD AMERITRADE http://www.tdameritrade.com US brokerage that includes quotes for 

stocks, mutual funds, options, index 

symbols. 

 

Free real-time streaming and integrated 

trading. 

DTN IQFeed http://www.iqfeed.net High-speed subscription real-time 

streaming quote service, including US 

and Canadian quotes for stocks, funds, 

options, futures, and more.  Includes 

options to increase streaming to hundreds 

of tickers at the same time. 

Yahoo! http://finance.yahoo.com 

 

US and Canadian stock markets, US 

mutual funds, index symbols.  Also 

supports many international exchanges, as 

per 

http://www.personalstockmonitor.com/su

pport/stock-market-exchanges.html 

Yahoo! UK http://uk.finance.yahoo.com A growing collection of European 

exchanges.  Currently covers over a 

dozen European markets including 

London, Paris, Milan, Barcelona, and 

Frankfurt. Visit their web site for the 

latest list of supported exchanges. 

Yahoo! Germany http://de.finance.yahoo.com Same exchanges as Yahoo! UK, but 

includes news headlines for the German 

markets. 

Yahoo! France http://fr.finance.yahoo.com Same exchanges as Yahoo! UK, but 

includes news headlines for the Paris 

market. 

Yahoo! Italy http://it.finance.yahoo.com Same exchanges as Yahoo! UK, but 

includes news headlines for the Italian 

markets. 

Yahoo! Australia http://au.finance.yahoo.com Australia and New Zealand markets. 

Yahoo! Argentina http://ar.finance.yahoo.com Buenos Aires, Caracas, San Pablo, 

Santiago 

Yahoo! Mexico http://mx.finance.yahoo.com Mexico, Caracas, and Santiago. 

Yahoo! Brazil http://br.finance.yahoo.com Brazil (BOVESPA) 

Yahoo! India http://in.finance.yahoo.com Bombay, Calcutta, NSE, Hong Kong, 

Jakarta, Korea, Singapore, Taiwan. 

Yahoo! Singapore http://sg.finance.yahoo.com A growing collection of mostly Far East 

exchanges, including Singapore, Hong 

Kong, Kuala Lumpur, Jakarta, India, 

Korea, and Taiwan. Visit their web site 

for the latest list of supported exchanges. 

PC Quote MarketSmart http://www.pcquote.com US and Canadian markets. 

Current support for PC Quote includes 

free delayed and subscription real time 

snapshot quotes.  These services are 

http://www.tdameritrade.com/
http://www.iqfeed.net/
http://finance.yahoo.com/
http://www.personalstockmonitor.com/support/stock-market-exchanges.html
http://www.personalstockmonitor.com/support/stock-market-exchanges.html
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referred to as MarketSmart Delayed and 

MarketSmart Real-Time on the PC Quote 

site and in Personal Stock Monitor. 

Canada.com Finance http://finance.canada.com Canadian stocks and mutual funds. 

Canada Stockwatch http://www.canada-

stockwatch.com 

Canadian stocks and mutual funds. 

Globeinvestor.com http://www.globeinvestor.com Canadian stocks and mutual funds 

GTrade http://www.gtrade.net International markets, real-time. Visit the 

web site to find out the latest information 

about exchanges covered by this server. 

 


